summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/carbonapi-web/carbonapi-web-1.1.ebuild')
-rw-r--r--app-metrics/carbonapi-web/carbonapi-web-1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-metrics/carbonapi-web/carbonapi-web-1.1.ebuild b/app-metrics/carbonapi-web/carbonapi-web-1.1.ebuild
new file mode 100644
index 000000000000..5b854a847cc2
--- /dev/null
+++ b/app-metrics/carbonapi-web/carbonapi-web-1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="graphite-web fork for standalone usage with carbonapi"
+HOMEPAGE="https://github.com/grobian/carbonapi-web"
+SRC_URI="https://github.com/grobian/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r webapp/content/*
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}