summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.40.4.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index f96fd019b053..383a0fea65a4 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -4,3 +4,6 @@ DIST prometheus-2.39.1.tar.gz 6045708 BLAKE2B 306a93c74257bbd33994538d7679d730a0
DIST prometheus-2.40.1-assets.tar.xz 45591668 BLAKE2B 76f1a6aa2eece8977b1573da51befc56dab7de95302b837d108a90b2e68640cbd7a37dc5ca09e385ba7f6ac5f4cac8fe902380e0c3c747909a27662e01e83c75 SHA512 38bb67689466bd864b7dff930d712f679fb2d56494641e99d5999a9df583c5cb9db24c5eccf951e944fb91cb564dfaf3905ea1159ff6975c672531fe7be34f8f
DIST prometheus-2.40.1-deps.tar.xz 253177652 BLAKE2B a0120addebe8ef5229af8f24624584b25bf625be9072d66b037ca9802190ec3c4451b735c9e31fbc9fd8a08a17e1c0c7f9c7602d1ff2f4bff1619c98a5eb1a35 SHA512 856dcb15f54eec34ca9216fe626165e08096f4114be62721b0edb3d07583ff0ff22d962e2d9ed0094626e42c5131c38908f1ba96327f741ff349b2f5fc237cd7
DIST prometheus-2.40.1.tar.gz 6156441 BLAKE2B 9b65733370e6f11ec559f7a4f2d80320d33d9cca29fb9609da3a255d90f06f14482976b5bbd58fc553b7d60a317cf8be0d1b6217128325f594ac9a4424cc3dbb SHA512 077c8aa2e4f6d51501b3281ab394afa26b0a9a8a7d5ed8f437b98e0bd83aceb3337bd877afc8942bf6b007dcfb53fbbafc746a5f305c9ba79bec55f0afbb0d58
+DIST prometheus-2.40.4-assets.tar.xz 45585656 BLAKE2B b187b6683c778b5e9746f1f9695e03303cf5481387bb0517afee56685edc62bbb82c515f8dfeeafeb09a74b57b540da49d1936c7ec74b3013adc7afc8f07ea5f SHA512 8a229504b66bac0ef2fa7a9caafc93fdf3e1c9aa33e892219e57a21b44355515e69a232db98ce4f5664fb98cb37cfb3ec619eb2a3ccf662474544dfdbbba580c
+DIST prometheus-2.40.4-deps.tar.xz 253189332 BLAKE2B ca2c2f3e111897ac47d71acc3046230608134c854f7af7a4c5ec1fe75dfbb61c6bf278fe00f77ecf65113b72cbd67171634a0fbf57ad09e3349a7e8f45791e33 SHA512 29bf419e45d389805b1f37256cb8a9ce9cc6cb88b3cd4a7a1681121f24158cce7aa5a949554f5344409ba4f683976866bfc766666e2a0a247996c135d2068b6f
+DIST prometheus-2.40.4.tar.gz 6156657 BLAKE2B a522b31516f5e26475afa2d59a7074b7deb2a70ffbf7cce6e3951bfeacc6dae6d8f59d1b1b591d1c59c0ac9839bc691ce315d55f7fe0a45be573e124f651764b SHA512 9b46f9f3b986929bdfe365645e43c0a3c2073b920e59cc512287f866506d7db7b83ffb2dbe24d1835fccc1b2cc781be7a373da5fb58c04521648981b19e81737
diff --git a/app-metrics/prometheus/prometheus-2.40.4.ebuild b/app-metrics/prometheus/prometheus-2.40.4.ebuild
new file mode 100644
index 000000000000..e6bbe21a4002
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.40.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=414d31aee6586a5f29e755ae059b7d7131f1c6c8
+MY_PV=v${PV/_rc/-rc.}
+
+# To create the assets tarball run the following:
+# git checkout <tag>
+# make assets-compress
+# tar -acf <tarball> web/ui
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/HEAD/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+ cp -a -n "${WORKDIR}"/web/ui web || die
+}
+
+src_compile() {
+ emake PROMU="${EPREFIX}"/usr/bin/promu common-build plugins
+}
+
+src_install() {
+ dobin prometheus promtool
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ dosym -r /usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym -r /usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}