summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/abook/abook-0.6.0_pre2.ebuild')
-rw-r--r--app-misc/abook/abook-0.6.0_pre2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/abook/abook-0.6.0_pre2.ebuild b/app-misc/abook/abook-0.6.0_pre2.ebuild
new file mode 100644
index 000000000000..e383d809c9ba
--- /dev/null
+++ b/app-misc/abook/abook-0.6.0_pre2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+MY_P="${P/_/}"
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client"
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="http://abook.sourceforge.net/devel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline
+ nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-vcard-import.patch
+ epatch "${FILESDIR}"/${P}-vcard-fix.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc BUGS ChangeLog FAQ README TODO sample.abookrc || die "dodoc failed"
+}