summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/abook')
-rw-r--r--app-misc/abook/abook-0.6.1-r4.ebuild (renamed from app-misc/abook/abook-0.6.1-r2.ebuild)33
-rw-r--r--app-misc/abook/files/abook-0.6.1-tinfo.patch18
-rw-r--r--app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch68
-rw-r--r--app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch31
-rw-r--r--app-misc/abook/files/abook-0.6.1-vformat.patch5
-rw-r--r--app-misc/abook/metadata.xml2
6 files changed, 120 insertions, 37 deletions
diff --git a/app-misc/abook/abook-0.6.1-r2.ebuild b/app-misc/abook/abook-0.6.1-r4.ebuild
index deec4303f985..1c383ef6435c 100644
--- a/app-misc/abook/abook-0.6.1-r2.ebuild
+++ b/app-misc/abook/abook-0.6.1-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
MY_P="${P/_/}"
DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client"
@@ -16,18 +16,25 @@ KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
IUSE="nls"
RDEPEND="
- sys-libs/ncurses
- sys-libs/readline
+ sys-libs/ncurses:=
+ sys-libs/readline:=
dev-libs/libvformat
nls? ( virtual/libintl )"
-
-DEPEND="nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+BDEPEND="
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
S="${WORKDIR}/${MY_P}"
DOCS=( BUGS ChangeLog FAQ README TODO sample.abookrc )
+
PATCHES=(
- "${FILESDIR}"/${PN}-0.6.1-tinfo.patch
+ "${FILESDIR}"/${PN}-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
+ "${FILESDIR}"/${PN}-0.6.1-use-newer-macro-for-readline.patch
"${FILESDIR}"/${PN}-0.6.1-vformat.patch
)
@@ -38,17 +45,13 @@ src_prepare() {
src_configure() {
econf \
- --with-curses \
- --with-readline \
--enable-vformat \
$(use_enable nls)
}
src_compile() {
- # bug 570428
- emake CFLAGS="${CFLAGS} -std=gnu89"
-}
+ # bug #570428
+ append-cflags -std=gnu89
-src_install() {
- default
+ emake CFLAGS="${CFLAGS}"
}
diff --git a/app-misc/abook/files/abook-0.6.1-tinfo.patch b/app-misc/abook/files/abook-0.6.1-tinfo.patch
deleted file mode 100644
index 3c12032932f1..000000000000
--- a/app-misc/abook/files/abook-0.6.1-tinfo.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -86,6 +86,7 @@
-
- AC_CHECK_LIB(ncursesw, initscr,
- [LIBS="$LIBS -lncursesw"
-+ AC_SEARCH_LIBS(cbreak, tinfow, LIBS="$LIBS -ltinfow")
- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncursesw; then
- CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
- fi
-@@ -93,6 +94,7 @@
- ac_widec_possible=no
- AC_CHECK_LIB(ncurses, initscr,
- [LIBS="$LIBS -lncurses"
-+ AC_SEARCH_LIBS(cbreak, tinfo, LIBS="$LIBS -ltinfo")
- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncurses; then
- CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
- fi
diff --git a/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch b/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
new file mode 100644
index 000000000000..8d7a6cddd7cb
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
@@ -0,0 +1,68 @@
+From 243d3c265289171f59de68f5da4de086afb58215 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 31 Jul 2021 03:21:28 +0100
+Subject: [PATCH] Use PKG_CHECK_MODULES for ncurses
+
+We don't _always_ have split tinfo, e.g. Prefix.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ Makefile.am | 4 ++--
+ configure.ac | 26 +-------------------------
+ 2 files changed, 3 insertions(+), 27 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 8faaa11..18c6892 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,8 +22,8 @@ abook_SOURCES = abook.c abook_rl.c database.c edit.c \
+ EXTRA_DIST = config.rpath ANNOUNCE BUGS FAQ abook.1 abookrc.5 sample.abookrc \
+ abook.spec contrib doc/HOWTO.translating_abook RELEASE_NOTES
+
+-abook_LDADD = @LIBINTL@
+-
++abook_CFLAGS = $(ncurses_CFLAGS)
++abook_LDADD = @LIBINTL@ $(ncurses_LIBS)
+
+ install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5
+diff --git a/configure.ac b/configure.ac
+index 5a9ae3b..73a7af0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,31 +74,7 @@ dnl -------------------
+ dnl (n)curses detection
+ dnl -------------------
+
+-abook_cv_curses=/usr
+-AC_ARG_WITH(curses, [ --with-curses=DIR Where ncurses is installed ],
+- [if test $withval != yes; then
+- abook_cv_curses=$withval
+- fi
+- if test x$abook_cv_curses != x/usr; then
+- LDFLAGS="-L${abook_cv_curses}/lib $LDFLAGS"
+- CPPFLAGS="$CPPFLAGS -I${abook_cv_curses}/include"
+- fi])
+-
+-AC_CHECK_LIB(ncursesw, initscr,
+- [LIBS="$LIBS -lncursesw"
+- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncursesw; then
+- CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
+- fi
+- AC_CHECK_HEADERS(ncurses.h)],[
+- ac_widec_possible=no
+- AC_CHECK_LIB(ncurses, initscr,
+- [LIBS="$LIBS -lncurses"
+- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncurses; then
+- CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
+- fi
+- AC_CHECK_HEADERS(ncurses.h)],
+- [CF_CURSES_LIBS])
+- ])
++PKG_CHECK_MODULES(ncurses, [ncursesw ncurses])
+
+ dnl --------------------------
+ dnl end of (n)curses detection
+--
+2.32.0
+
diff --git a/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch b/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch
new file mode 100644
index 000000000000..1a35e636964d
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch
@@ -0,0 +1,31 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 21 Apr 2021 06:20:13 +0100
+Subject: Use more modern autoconf archive macro for readline
+
+The previous macro used was pretty obsolete and certainly didn't work
+on Gentoo Prefix on Darwin anyway.
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,19 +86,9 @@ dnl ------------------
+ dnl readline detection
+ dnl ------------------
+
+-abook_cv_readline=/usr
+-AC_ARG_WITH(readline, [ --with-readline=DIR Where readline is installed ],
+- [if test $withval != yes; then
+- abook_cv_readline=$withval
+- fi
+- if test x$abook_cv_readline != x/usr; then
+- LDFLAGS="-L${abook_cv_readline}/lib $LDFLAGS"
+- CPPFLAGS="$CPPFLAGS -I${abook_cv_readline}/include"
+- fi])
+-
+-AC_LIB_READLINE
+-
+-if test x$ac_cv_lib_readline = xno -o x$ac_cv_lib_readline_history = xno; then
++AX_LIB_READLINE
++
++if test x$ax_cv_lib_readline = xno -o x$ax_cv_lib_readline_history = xno; then
+ AC_MSG_ERROR([*** readline library not found or it doesn't support history ***])
+ fi
+
diff --git a/app-misc/abook/files/abook-0.6.1-vformat.patch b/app-misc/abook/files/abook-0.6.1-vformat.patch
index 0808852e6b20..07a68a8ecb11 100644
--- a/app-misc/abook/files/abook-0.6.1-vformat.patch
+++ b/app-misc/abook/files/abook-0.6.1-vformat.patch
@@ -1,6 +1,5 @@
-diff -ru abook-0.6.1.orig/configure.ac abook-0.6.1/configure.ac
---- abook-0.6.1.orig/configure.ac 2020-05-24 19:10:09.826143646 +0200
-+++ abook-0.6.1/configure.ac 2020-05-24 19:10:52.088381318 +0200
+--- a/configure.ac
++++ b/configure.ac
@@ -140,6 +140,7 @@
if test x$vformat = xtrue; then
AC_CHECK_HEADER([vf_iface.h], [
diff --git a/app-misc/abook/metadata.xml b/app-misc/abook/metadata.xml
index dd19a67bf751..b002f8fa54f4 100644
--- a/app-misc/abook/metadata.xml
+++ b/app-misc/abook/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>cedk@gentoo.org</email>