summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/binwalk/binwalk-2.0.1.ebuild')
-rw-r--r--app-misc/binwalk/binwalk-2.0.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-misc/binwalk/binwalk-2.0.1.ebuild b/app-misc/binwalk/binwalk-2.0.1.ebuild
deleted file mode 100644
index ac89f6c52727..000000000000
--- a/app-misc/binwalk/binwalk-2.0.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for identifying files embedded inside firmware images"
-HOMEPAGE="https://github.com/devttys0/binwalk"
-SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="graph"
-
-RDEPEND="
- app-crypt/ssdeep
- sys-apps/file[${PYTHON_USEDEP}]
- graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-makefile.patch
- "${FILESDIR}"/${P}-libs.patch
-)
-
-python_configure_all() {
- econf --disable-bundles
-}
-
-python_compile_all() {
- emake
-}
-
-python_install_all() {
- local DOCS=( API.md INSTALL.md )
- distutils-r1_python_install_all
-
- dolib.so src/C/*/*.so
-}