summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/binwalk/binwalk-2.1.1.ebuild')
-rw-r--r--app-misc/binwalk/binwalk-2.1.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-misc/binwalk/binwalk-2.1.1.ebuild b/app-misc/binwalk/binwalk-2.1.1.ebuild
deleted file mode 100644
index c69739d3e4da..000000000000
--- a/app-misc/binwalk/binwalk-2.1.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86 ~x64-macos"
-fi
-
-DESCRIPTION="A tool for identifying files embedded inside firmware images"
-HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="graph"
-
-RDEPEND="
- graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}"/0001-Added-check-for-backports.lzma-when-importing-lzma-m.patch )
-
-python_install_all() {
- local DOCS=( API.md INSTALL.md README.md )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "binwalk has many optional dependencies to automatically"
- elog "extract/decompress data, see INSTALL.md for more details."
- fi
-}