summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/binwalk/binwalk-9999.ebuild')
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index 7c288ad1f32b..53c023e8014b 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -1,33 +1,28 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 optfeature
if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ReFirmLabs/binwalk.git"
+ EGIT_REPO_URI="https://github.com/OSPG/binwalk.git"
inherit git-r3
else
- SRC_URI="https://github.com/ReFirmLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/OSPG/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
fi
DESCRIPTION="A tool for identifying files embedded inside firmware images"
-HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
+HOMEPAGE="https://github.com/OSPG/binwalk"
LICENSE="MIT"
SLOT="0"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch
-
-)
-
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_install_all() {
local DOCS=( API.md INSTALL.md README.md )
@@ -35,6 +30,9 @@ python_install_all() {
}
pkg_postinst() {
+ optfeature "entropy graph" dev-python/matplotlib
+ optfeature "disassembly" dev-libs/capstone[python]
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "binwalk has many optional dependencies to automatically"
elog "extract/decompress data, see INSTALL.md for more details."