summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/bottlerocket')
-rw-r--r--app-misc/bottlerocket/Manifest1
-rw-r--r--app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild45
-rw-r--r--app-misc/bottlerocket/metadata.xml7
3 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/bottlerocket/Manifest b/app-misc/bottlerocket/Manifest
new file mode 100644
index 000000000000..17efb6b26253
--- /dev/null
+++ b/app-misc/bottlerocket/Manifest
@@ -0,0 +1 @@
+DIST bottlerocket-0.04c.tar.gz 40533 SHA256 deb8fbf8856f87af15fa9883e07b1fddb2aa78f6b4c7d119ae4bd664dc1d19ae SHA512 37673bd9a519307f0ae3003f3a458dbb99d4fd0c96ebaa664f4967fe45b20c1132828c3c7a31e769157e6034c43c9cdcd1ecac8c6791812d2a04e93d4c0c6888 WHIRLPOOL 838f4267ea55a70fff2a50d457e90d2597ff6254383ae7d420075cb32782a8544a6491c9109e42f066c8408f14ed08654756f783184fb667471a7c7a4dcf12e6
diff --git a/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild b/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild
new file mode 100644
index 000000000000..46da14cd9b7e
--- /dev/null
+++ b/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="CLI interface to the X-10 Firecracker Kit"
+HOMEPAGE="http://www.linuxha.com/bottlerocket/"
+SRC_URI="http://www.linuxha.com/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+src_prepare() {
+ # inset LDFLAGS
+ sed -i Makefile.in \
+ -e 's| -O2 ||g' \
+ -e '/ -o br /s|${CFLAGS}|& $(LDFLAGS)|g' \
+ || die "sed Makefile.in"
+}
+
+src_configure() {
+ econf --with-x10port=/dev/firecracker
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall"
+ dodoc README
+}
+
+pkg_postinst() {
+ elog
+ elog "Be sure to create a /dev/firecracker symlink to the"
+ elog "serial port that has the Firecracker serial interface"
+ elog "installed on it."
+ elog
+}
diff --git a/app-misc/bottlerocket/metadata.xml b/app-misc/bottlerocket/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-misc/bottlerocket/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>