summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/carbon-c-relay/carbon-c-relay-2.3.ebuild')
-rw-r--r--app-misc/carbon-c-relay/carbon-c-relay-2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/carbon-c-relay/carbon-c-relay-2.3.ebuild b/app-misc/carbon-c-relay/carbon-c-relay-2.3.ebuild
new file mode 100644
index 000000000000..963f0fca75de
--- /dev/null
+++ b/app-misc/carbon-c-relay/carbon-c-relay-2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs user
+
+DESCRIPTION="Enhanced C version of Carbon relay, aggregator and rewriter"
+HOMEPAGE="https://github.com/grobian/carbon-c-relay"
+SRC_URI="https://github.com/grobian/carbon-c-relay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ enewgroup carbon
+ enewuser carbon -1 -1 -1 carbon
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ newbin relay ${PN}
+ dodoc ChangeLog.md
+ doman ${PN}.1
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}