summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cdargs')
-rw-r--r--app-misc/cdargs/Manifest1
-rw-r--r--app-misc/cdargs/cdargs-2.1.ebuild65
-rw-r--r--app-misc/cdargs/files/cdargs-2.1-musl.patch17
-rw-r--r--app-misc/cdargs/metadata.xml3
4 files changed, 86 insertions, 0 deletions
diff --git a/app-misc/cdargs/Manifest b/app-misc/cdargs/Manifest
index 84a43c216534..b42ef7e986c8 100644
--- a/app-misc/cdargs/Manifest
+++ b/app-misc/cdargs/Manifest
@@ -1 +1,2 @@
DIST cdargs-1.35.tar.gz 74103 BLAKE2B 06fa5b4ed7c00dbcceeda28c2b02dd46431748434a692f3690885dc1141764e8aacef2e09cab57cf1baab32cb66c5c39a846a09fd6381723f47cd8dc98c8584f SHA512 13df5d18de6f62309a0ecccc0dd95508d81d1955f87cfd2962360d3b7d74c5cdc2b0d2e00f7a4f1e7556bfbcbd3e2ecf4847a1a48ab47442e6d2d5a36db0cf0c
+DIST cdargs-2.1.tar.gz 127945 BLAKE2B a0020de2f019985f40910ef95aeb189cd3bd6e701aab986e2b13ff3a43965c29bc940e7553ea8722147e2fd8e21ce852d075561832a9e4972cf9d3ba8ee043ba SHA512 5914d5d2096386db523115c0c6d26f6f328287e0e87d829e19217ab9ef34f70d7fd6af14d73d5020f61d90342ce8ec81a1364000531d2715ef6ba961ae0d222a
diff --git a/app-misc/cdargs/cdargs-2.1.ebuild b/app-misc/cdargs/cdargs-2.1.ebuild
new file mode 100644
index 000000000000..956e6cb7051b
--- /dev/null
+++ b/app-misc/cdargs/cdargs-2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson elisp-common
+
+DESCRIPTION="Bookmarks and browser for the shell builtin cd command"
+HOMEPAGE="https://www.skamphausen.de/cgi-bin/ska/CDargs https://github.com/cbxbiker61/cdargs"
+SRC_URI="https://github.com/cbxbiker61/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="emacs"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.35-format_security.patch
+ "${FILESDIR}"/${PN}-1.35-tinfo.patch
+ "${FILESDIR}"/${PN}-2.1-musl.patch
+)
+
+src_compile() {
+ meson_src_compile
+
+ use emacs && elisp-compile contrib/cdargs.el
+}
+
+src_install() {
+ meson_src_install
+
+ cd "${S}"/contrib || die
+ insinto /usr/share/cdargs
+ doins cdargs-bash.sh cdargs-tcsh.csh
+
+ if use emacs ; then
+ elisp-install ${PN} cdargs.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ elog "Add the following line to your ~/.bashrc to enable cdargs helper"
+ elog "functions/aliases in your environment:"
+ elog "[ -f /usr/share/cdargs/cdargs-bash.sh ] && \\ "
+ elog " source /usr/share/cdargs/cdargs-bash.sh"
+ elog
+ elog "Users of tcshell will find cdargs-tcsh.csh there with a reduced"
+ elog "feature set. See INSTALL file in the documentation directory for"
+ elog "more information."
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-misc/cdargs/files/cdargs-2.1-musl.patch b/app-misc/cdargs/files/cdargs-2.1-musl.patch
new file mode 100644
index 000000000000..81130482a500
--- /dev/null
+++ b/app-misc/cdargs/files/cdargs-2.1-musl.patch
@@ -0,0 +1,17 @@
+In Musl path max is in limits.h and not automatically pulled in
+
+Pascal Jäger <pascal.jaeger@leimstift.de> (2023-10-14)
+
+Bug: https://bugs.gentoo.org/713962
+upstream PR: https://github.com/cbxbiker61/cdargs/pull/8
+
+--- a/src/cdargs.cc
++++ b/src/cdargs.cc
+@@ -56,6 +56,7 @@ using namespace std;
+ # include <unistd.h>
+ # include <signal.h>
+ # include <string.h>
++# include <limits.h>
+
+ //# if defined(USE_NCURSES) && !defined(RENAMED_NCURSES)
+ # if defined(HAVE_NCURSES_H)
diff --git a/app-misc/cdargs/metadata.xml b/app-misc/cdargs/metadata.xml
index 6258504e5133..e895ffabed55 100644
--- a/app-misc/cdargs/metadata.xml
+++ b/app-misc/cdargs/metadata.xml
@@ -5,4 +5,7 @@
<email>shell-tools@gentoo.org</email>
<name>Gentoo Shell Tools Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">cbxbiker61/cdargs</remote-id>
+ </upstream>
</pkgmetadata>