summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cdctl/cdctl-0.15.ebuild')
-rw-r--r--app-misc/cdctl/cdctl-0.15.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/cdctl/cdctl-0.15.ebuild b/app-misc/cdctl/cdctl-0.15.ebuild
new file mode 100644
index 000000000000..39b43cfc51bb
--- /dev/null
+++ b/app-misc/cdctl/cdctl-0.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to control your cd/dvd drive"
+HOMEPAGE="http://cdctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="x86 ppc amd64 ppc64"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.in.patch
+ epatch "${FILESDIR}"/${P}-cdc_ioctls.patch
+}
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS NUTSANDBOLTS PUBLICKEY README
+}