summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cdctl')
-rw-r--r--app-misc/cdctl/cdctl-0.16.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/app-misc/cdctl/cdctl-0.16.ebuild b/app-misc/cdctl/cdctl-0.16.ebuild
index 32444005ab91..e552ac85380b 100644
--- a/app-misc/cdctl/cdctl-0.16.ebuild
+++ b/app-misc/cdctl/cdctl-0.16.ebuild
@@ -1,29 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils autotools toolchain-funcs
+inherit autotools
DESCRIPTION="Utility to control your cd/dvd drive"
HOMEPAGE="http://cdctl.sourceforge.net/"
SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="free-noncomm"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-
-DEPEND=""
-S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-0.16-Makefile.in.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.16-Makefile.in.patch
-
+ default
eautoreconf
}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}