summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dateutils')
-rw-r--r--app-misc/dateutils/Manifest3
-rw-r--r--app-misc/dateutils/dateutils-0.4.10.ebuild36
-rw-r--r--app-misc/dateutils/dateutils-0.4.6.ebuild29
-rw-r--r--app-misc/dateutils/dateutils-0.4.9.ebuild36
-rw-r--r--app-misc/dateutils/dateutils-9999.ebuild36
-rw-r--r--app-misc/dateutils/files/dateutils-0.4.6-unportable-sys-sysctl_h.patch10
-rw-r--r--app-misc/dateutils/metadata.xml24
7 files changed, 129 insertions, 45 deletions
diff --git a/app-misc/dateutils/Manifest b/app-misc/dateutils/Manifest
index 7d394ff680f1..edfdc3dbca37 100644
--- a/app-misc/dateutils/Manifest
+++ b/app-misc/dateutils/Manifest
@@ -1 +1,2 @@
-DIST dateutils-0.4.6.tar.xz 640552 BLAKE2B 7f1b5bef1465063f46a7bc4b64ed1d645b3bf827aa17b7c962bf3e2731a031f8cf074970aad618157283f0303222413c7be80a72bdcc65bd0918120216542295 SHA512 014e8411774250d2862943bbbdd69cc7ec2ca934349272ae7c44b136a57ef30c23f841018cc38f86d49e2348b2199848076db224e3653d6d7337a3f17709c8cb
+DIST dateutils-0.4.10.tar.xz 652548 BLAKE2B b1fe3b07edfd223c9265df99888bf2edc37458b487b0f3b913f4c19e23b86d4a7f8cb3f0610bf140e6ce0233a9008ccd26cbe0b1462c5f85b2424cd39ffcbdb7 SHA512 04a9fff177596bb9bc47d3b221865bbeafeafbc708385610845a1cdcb2a7fa379e8d9363cce578836ae121dab7ee64e19f61d82e8f222250e52d23c5f43cf521
+DIST dateutils-0.4.9.tar.xz 651024 BLAKE2B 9b9bab5f990689a367fa574c20113c01f4847cdcced47275b992655cb91cd14076c22e2d550a969c20ef979b63156c72a485c42105022e522dce4d1376aa0393 SHA512 b5cda838f8fa01e4208e11842f835503357c02b4a21b003db08ef88763a65f26ad2cd6f5d71c80b499d4e5ee5c0b4e552469ef91aa6cd02ebe5c5d2ad6e3105e
diff --git a/app-misc/dateutils/dateutils-0.4.10.ebuild b/app-misc/dateutils/dateutils-0.4.10.ebuild
new file mode 100644
index 000000000000..5d54f490994d
--- /dev/null
+++ b/app-misc/dateutils/dateutils-0.4.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command line date and time utilities"
+HOMEPAGE="https://www.fresse.org/dateutils/ https://github.com/hroptatyr/dateutils"
+
+case "${PV}" in
+ 9999)
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/hroptatyr/dateutils.git"
+ ;;
+ *)
+ SRC_URI="https://github.com/hroptatyr/dateutils/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+esac
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="app-arch/xz-utils"
+DEPEND="sys-libs/timezone-data"
+
+# bug 429810
+RDEPEND="${DEPEND}
+ !sys-fabric/dapl"
+
+src_prepare() {
+ default
+ [[ "${PV}" = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf CFLAGS="${CFLAGS}"
+}
diff --git a/app-misc/dateutils/dateutils-0.4.6.ebuild b/app-misc/dateutils/dateutils-0.4.6.ebuild
deleted file mode 100644
index 7b12131bfecd..000000000000
--- a/app-misc/dateutils/dateutils-0.4.6.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="command line date and time utilities"
-HOMEPAGE="https://www.fresse.org/dateutils/"
-SRC_URI="https://bitbucket.org/hroptatyr/${PN}/downloads/${P}.tar.xz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="app-arch/xz-utils
- sys-libs/timezone-data"
-
-# bug 429810
-RDEPEND="!sys-fabric/dapl"
-
-PATCHES=( "${FILESDIR}"/${P}-unportable-sys-sysctl_h.patch )
-
-src_compile() {
- emake CFLAGS="${CFLAGS}"
-}
-
-src_test() {
- # parallel tests failure
- emake CFLAGS="${CFLAGS}" -j1 check
-}
diff --git a/app-misc/dateutils/dateutils-0.4.9.ebuild b/app-misc/dateutils/dateutils-0.4.9.ebuild
new file mode 100644
index 000000000000..69d0857f63a4
--- /dev/null
+++ b/app-misc/dateutils/dateutils-0.4.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command line date and time utilities"
+HOMEPAGE="https://www.fresse.org/dateutils/ https://github.com/hroptatyr/dateutils"
+
+case "${PV}" in
+ 9999)
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/hroptatyr/dateutils.git"
+ ;;
+ *)
+ SRC_URI="https://github.com/hroptatyr/dateutils/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 x86"
+esac
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="app-arch/xz-utils"
+DEPEND="sys-libs/timezone-data"
+
+# bug 429810
+RDEPEND="${DEPEND}
+ !sys-fabric/dapl"
+
+src_prepare() {
+ default
+ [[ "${PV}" = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf CFLAGS="${CFLAGS}"
+}
diff --git a/app-misc/dateutils/dateutils-9999.ebuild b/app-misc/dateutils/dateutils-9999.ebuild
new file mode 100644
index 000000000000..7c1baaa588b0
--- /dev/null
+++ b/app-misc/dateutils/dateutils-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command line date and time utilities"
+HOMEPAGE="https://www.fresse.org/dateutils/ https://github.com/hroptatyr/dateutils"
+
+case "${PV}" in
+ 9999)
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/hroptatyr/dateutils.git"
+ ;;
+ *)
+ SRC_URI="https://github.com/hroptatyr/dateutils/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+esac
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="app-arch/xz-utils"
+DEPEND="sys-libs/timezone-data"
+
+# bug 429810
+RDEPEND="${DEPEND}
+ !sys-fabric/dapl"
+
+src_prepare() {
+ default
+ [[ "${PV}" = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf CFLAGS="${CFLAGS}"
+}
diff --git a/app-misc/dateutils/files/dateutils-0.4.6-unportable-sys-sysctl_h.patch b/app-misc/dateutils/files/dateutils-0.4.6-unportable-sys-sysctl_h.patch
deleted file mode 100644
index dc310ea7812c..000000000000
--- a/app-misc/dateutils/files/dateutils-0.4.6-unportable-sys-sysctl_h.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/build-aux/yuck.c
-+++ b/build-aux/yuck.c
-@@ -65,7 +65,6 @@
- #include <sys/wait.h>
- #include <sys/stat.h>
- #include <sys/types.h>
--#include <sys/sysctl.h>
- #include <time.h>
- #if defined WITH_SCMVER
- # include <yuck-scmver.h>
diff --git a/app-misc/dateutils/metadata.xml b/app-misc/dateutils/metadata.xml
index 11d80f64486e..3e9ffe7cb21b 100644
--- a/app-misc/dateutils/metadata.xml
+++ b/app-misc/dateutils/metadata.xml
@@ -1,8 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="bitbucket">hroptatyr/dateutils</remote-id>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <email>coppens.matthias.abc@gmail.com</email>
+ <name>Matthias Coppens</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <name>Sebastian Freundt</name>
+ <email>devel@fresse.org</email>
+ </maintainer>
+ <changelog>https://www.fresse.org/dateutils/changelog.html</changelog>
+ <doc>https://www.fresse.org/dateutils/#examples</doc>
+ <remote-id type="github">hroptatyr/dateutils</remote-id>
+ <remote-id type="bitbucket">hroptatyr/dateutils</remote-id>
+ </upstream>
</pkgmetadata>