summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild')
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild
new file mode 100644
index 000000000000..c702318cfafa
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20230627.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="https://github.com/ddccontrol/ddccontrol-db"
+SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/intltool
+ dev-perl/XML-Parser
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ touch db/options.xml.h ABOUT-NLS config.rpath || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}