summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ddcutil')
-rw-r--r--app-misc/ddcutil/Manifest1
-rw-r--r--app-misc/ddcutil/ddcutil-0.8.6.ebuild106
-rw-r--r--app-misc/ddcutil/metadata.xml3
3 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/ddcutil/Manifest b/app-misc/ddcutil/Manifest
index 6ee209a81d56..5976b0abda9e 100644
--- a/app-misc/ddcutil/Manifest
+++ b/app-misc/ddcutil/Manifest
@@ -1 +1,2 @@
DIST ddcutil-0.8.4.tar.gz 558405 BLAKE2B 4bb93d6b9b28a17ef182c1f39e3b6351070c5541fd8eefccde2a6d771e28a8c656abe1e00a58ee935290cba79af09b1c2d6b611532827455b5ec83532bbb46c4 SHA512 e7bf78295a008607ef520e055873acc0bac6d94b850a6ea1f7d4a4ea9e080d23b4b7d82e5725a220ff120ab1523aa320265ba22671982625c10088521c72a14c
+DIST ddcutil-0.8.6.tar.gz 613272 BLAKE2B ce7072a819c5a2aa125ae8f6d5550cf0a516714f0635672015a0c24c9e525d34139c903ce7791955e0b30b8d4c66e94453eed60f8d8d024caccb49204d6fb853 SHA512 4ec473a37dc135700f4ce06634e6aa303199f4d743fba02c04ca509d0c31d45f59da7c6cd9818efc1fd8bc20dae518c5656fc8a38e9f00057677b1e997434fb0
diff --git a/app-misc/ddcutil/ddcutil-0.8.6.ebuild b/app-misc/ddcutil/ddcutil-0.8.6.ebuild
new file mode 100644
index 000000000000..6444e7739e03
--- /dev/null
+++ b/app-misc/ddcutil/ddcutil-0.8.6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic linux-info udev user
+
+DESCRIPTION="Program for querying and changing monitor settings"
+HOMEPAGE="http://www.ddcutil.com/"
+SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="drm usb-monitor user-permissions video_cards_nvidia X"
+REQUIRED_USE="drm? ( X )"
+
+RDEPEND="dev-libs/glib:2
+ sys-apps/i2c-tools
+ virtual/udev
+ drm? ( x11-libs/libdrm )
+ usb-monitor? (
+ dev-libs/hidapi
+ virtual/libusb:1
+ sys-apps/usbutils
+ )
+ X? (
+ x11-libs/libXrandr
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ # This program needs /dev/ic2-* devices to communicate with the monitor.
+ CONFIG_CHECK="~I2C_CHARDEV"
+ ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
+ if use usb-monitor; then
+ CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
+ ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
+ ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Bug 607818.
+ replace-flags -O3 -O2
+
+ local myeconfargs=(
+ $(use_enable drm)
+ $(use_enable usb-monitor usb)
+ $(use_enable X x11)
+ --enable-lib
+ --disable-cffi
+ --disable-cython
+ --disable-swig
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if use user-permissions; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
+ if use usb-monitor; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use user-permissions; then
+ enewgroup i2c
+ einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
+ einfo "users to the i2c group: usermod -aG i2c user"
+ einfo "Restart the computer or reload the i2c-dev module to activate"
+ einfo "the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
+
+ if use usb-monitor; then
+ enewgroup video
+ einfo "To allow non-root users access to USB monitors, add those users"
+ einfo "to the video group: usermod -aG video user"
+ einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
+ einfo "the monitor to activate the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/usb/"
+ fi
+
+ udev_reload
+ fi
+
+ if use video_cards_nvidia; then
+ ewarn "Please read the following webpage on proper usage with the nVidia "
+ ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
+ fi
+}
diff --git a/app-misc/ddcutil/metadata.xml b/app-misc/ddcutil/metadata.xml
index 3eec1aa83b5c..ac2fd91b713b 100644
--- a/app-misc/ddcutil/metadata.xml
+++ b/app-misc/ddcutil/metadata.xml
@@ -18,6 +18,9 @@
a USB connection.
</longdescription>
<use>
+ <flag name="drm" restrict="&gt;=app-misc/ddcutil-0.8.5">
+ Use <pkg>x11-libs/libdrm</pkg> for more verbose diagnostics.
+ </flag>
<flag name="user-permissions">
Adds a udev rules to allow non-root users in the i2c group to
access the /dev/i2c-* devices. If usb-monitor is selected, users