summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild')
-rw-r--r--app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild b/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
deleted file mode 100644
index 883ebd7c7fee..000000000000
--- a/app-misc/dfshow/dfshow-0.9.1_beta-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1
-
-MY_PV="${PV//_beta/-beta}"
-DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT"
-HOMEPAGE="https://github.com/roberthawdon/dfshow"
-SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-libs/libconfig:=
- sys-libs/ncurses:0=
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am ||
- die "sed in Makefile.am failed"
-
- eautoreconf
-}
-
-src_install() {
- default
-
- newbashcomp "${S}/misc/auto-completion/bash/sf-completion.bash" sf-completion
- newbashcomp "${S}/misc/auto-completion/bash/show-completion.bash" show-completion
-
- insinto /usr/share/zsh/site-functions
- doins "${S}/misc/auto-completion/zsh/_sf"
- doins "${S}/misc/auto-completion/zsh/_show"
-}