summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/getopt')
-rw-r--r--app-misc/getopt/Manifest2
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-libintl.patch34
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-longrename.patch118
-rw-r--r--app-misc/getopt/files/getopt-1.1.5-longrename.patch79
-rw-r--r--app-misc/getopt/getopt-1.1.4.ebuild64
-rw-r--r--app-misc/getopt/getopt-1.1.5.ebuild65
6 files changed, 0 insertions, 362 deletions
diff --git a/app-misc/getopt/Manifest b/app-misc/getopt/Manifest
index b7d7a89d5ea8..a3c5f8091c45 100644
--- a/app-misc/getopt/Manifest
+++ b/app-misc/getopt/Manifest
@@ -1,3 +1 @@
-DIST getopt-1.1.4.tar.gz 37163 SHA256 41083d9993c26792851e79b81a0991996a3f61e14998fdd607615cc3bf933bab SHA512 9ec9b5ca50a02b6ae772b133408e61fb9fcb5840c00f23d1c836a9c7ee86778211dcb1ecf5cdcaf9e2488b2db0671e29bc8be55f1a7ca4f1d48cc3921dfe04ad WHIRLPOOL 64e4942064930303ecc8cd6ea22f93ccd0c34415815f1e4fc43d2786b1e3bd511fac6d0aa6ef470b0a026a7776c4e0b345b1beada0c972203808232d0c331727
-DIST getopt-1.1.5.tar.gz 51794 SHA256 11893276b94b1629606ab75772143918a5713259950fbf4216288e246f19fbb6 SHA512 43597a1a8dd1dc188b6b4f0a8f8d438456013276aa1c719889e242ba2b526dccbca2fccd3d82d1541f4e0920fd277c101a436ed0c208124227481f792cb1cf75 WHIRLPOOL c5de1797b0c294a404ef8e801d86677d0b84fd6974e5d5ad8d234ae28db5446d0b13766362ecac459b3f8ce07d56282a3f0274b460d5d95118000762d9374815
DIST getopt-1.1.6.tar.gz 58926 SHA256 d0bf1dc642a993e7388a1cddfb9409bed375c21d5278056ccca3a0acd09dc5fe SHA512 aa5476e729f33ddd3f32f38b2565da319fdfe034f11549218d5d9953e70dad764e0d9a82bb10efe4043c86ae87f944619b8a2f29a197f592bd855699961d8e10 WHIRLPOOL 0fa96415fa5d9b001313b1491a0f260922dbb52ac72d6242e6ff332ac802e3d6cac2401c8e8a8f9cc09376d3c51f4b1cc3bd0f976dc857cd72c1ffc7b1d770da
diff --git a/app-misc/getopt/files/getopt-1.1.4-libintl.patch b/app-misc/getopt/files/getopt-1.1.4-libintl.patch
deleted file mode 100644
index 232e487b3d31..000000000000
--- a/app-misc/getopt/files/getopt-1.1.4-libintl.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: getopt-1.1.4/Makefile
-===================================================================
---- getopt-1.1.4.orig/Makefile
-+++ getopt-1.1.4/Makefile
-@@ -33,7 +33,10 @@ MSGFMT=msgfmt
- LANGUAGES = cs de es fr it ja nl pt_BR
- MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
-
--CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITH_GETTEXT=$(WITH_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX
-+CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX
-+ifeq ($(WITHOUT_GETTEXT),1)
-+CPPFLAGS+=-DWITHOUT_GETTEXT
-+endif
- ifeq ($(LIBCGETOPT),0)
- CPPFLAGS+=-I./gnu
- endif
-@@ -62,7 +65,7 @@ clean: clean_po
- -$(RM) $(objects) $(binaries)
-
- getopt: $(objects)
-- $(CC) $(LDFLAGS) -o $@ $(objects)
-+ $(CC) $(LDFLAGS) -o $@ $(objects) $(LIBINTL)
-
- install: getopt install_po
- $(INSTALL) -m 755 -d $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
-@@ -75,7 +78,7 @@ install_doc:
- getopt-test.bash getopt-test.tcsh \
- $(DESTDIR)$(getoptdir)
-
--ifeq ($(WITH_GETTEXT),1)
-+ifeq ($(WITHOUT_GETTEXT),0)
- all_po: $(MOFILES)
- install_po: all_po
- $(INSTALL) -m 755 -d $(DESTDIR)$(localedir)
diff --git a/app-misc/getopt/files/getopt-1.1.4-longrename.patch b/app-misc/getopt/files/getopt-1.1.4-longrename.patch
deleted file mode 100644
index dc3ecb066378..000000000000
--- a/app-misc/getopt/files/getopt-1.1.4-longrename.patch
+++ /dev/null
@@ -1,118 +0,0 @@
-Index: getopt-1.1.4/getopt.c
-===================================================================
---- getopt-1.1.4.orig/getopt.c
-+++ getopt-1.1.4/getopt.c
-@@ -88,7 +88,7 @@ void *our_malloc(size_t size)
- {
- void *ret=malloc(size);
- if (! ret) {
-- fprintf(stderr,_("%s: Out of memory!\n"),"getopt");
-+ fprintf(stderr,_("%s: Out of memory!\n"),"getopt-long");
- exit(3);
- }
- return(ret);
-@@ -98,7 +98,7 @@ void *our_realloc(void *ptr, size_t size
- {
- void *ret=realloc(ptr,size);
- if (! ret && size) {
-- fprintf(stderr,_("%s: Out of memory!\n"),"getopt");
-+ fprintf(stderr,_("%s: Out of memory!\n"),"getopt-long");
- exit(3);
- }
- return(ret);
-@@ -231,8 +231,8 @@ int generate_output(char * argv[],int ar
- void parse_error(const char *message)
- {
- if (message)
-- fprintf(stderr,"getopt: %s\n",message);
-- fputs(_("Try `getopt --help' for more information.\n"),stderr);
-+ fprintf(stderr,"getopt-long: %s\n",message);
-+ fputs(_("Try `getopt-long --help' for more information.\n"),stderr);
- exit(2);
- }
-
-@@ -323,10 +323,10 @@ void set_shell(const char *new_shell)
-
- void print_help(void)
- {
-- fputs(_("Usage: getopt optstring parameters\n"),stderr);
-- fputs(_(" getopt [options] [--] optstring parameters\n"),stderr);
-- fputs(_(" getopt [options] -o|--options optstring [options] [--]\n"),stderr);
-- fputs(_(" parameters\n"),stderr);
-+ fputs(_("Usage: getopt-long optstring parameters\n"),stderr);
-+ fputs(_(" getopt-long [options] [--] optstring parameters\n"),stderr);
-+ fputs(_(" getopt-long [options] -o|--options optstring [options] [--]\n"),stderr);
-+ fputs(_(" parameters\n"),stderr);
- fputs(_(" -a, --alternative Allow long options starting with single -\n"),stderr);
- fputs(_(" -h, --help This small usage guide\n"),stderr);
- fputs(_(" -l, --longoptions=longopts Long options to be recognized\n"),stderr);
-@@ -335,7 +335,7 @@ void print_help(void)
- fputs(_(" -q, --quiet Disable error reporting by getopt(3)\n"),stderr);
- fputs(_(" -Q, --quiet-output No normal output\n"),stderr);
- fputs(_(" -s, --shell=shell Set shell quoting conventions\n"),stderr);
-- fputs(_(" -T, --test Test for getopt(1) version\n"),stderr);
-+ fputs(_(" -T, --test Test for getopt-long(1) version\n"),stderr);
- fputs(_(" -u, --unqote Do not quote the output\n"),stderr);
- fputs(_(" -V, --version Output version information\n"),stderr);
- exit(2);
-@@ -443,7 +443,7 @@ int main(int argc, char *argv[])
- quote=0;
- break;
- case 'V':
-- printf(_("getopt (enhanced) 1.1.4\n"));
-+ printf(_("getopt-long (enhanced) 1.1.4\n"));
- exit(0);
- case '?':
- case ':':
-Index: getopt-1.1.4/getopt-parse.bash
-===================================================================
---- getopt-1.1.4.orig/getopt-parse.bash
-+++ getopt-1.1.4/getopt-parse.bash
-@@ -19,7 +19,7 @@
- # Note that we use `"$@"' to let each command-line parameter expand to a
- # separate word. The quotes around `$@' are essential!
- # We need TEMP as the `eval set --' would nuke the return value of getopt.
--TEMP=`getopt -o ab:c:: --long a-long,b-long:,c-long:: \
-+TEMP=`getopt-long -o ab:c:: --long a-long,b-long:,c-long:: \
- -n 'example.bash' -- "$@"`
-
- if [ $? != 0 ] ; then echo "Terminating..." >&2 ; exit 1 ; fi
-Index: getopt-1.1.4/getopt-parse.tcsh
-===================================================================
---- getopt-1.1.4.orig/getopt-parse.tcsh
-+++ getopt-1.1.4/getopt-parse.tcsh
-@@ -26,7 +26,7 @@
- # as a list. The ':q` copies that list without doing any substitutions:
- # each element of argv becomes a separate argument for getopt. The braces
- # are needed because the result is also a list.
--set temp=(`getopt -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
-+set temp=(`getopt-long -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
- if ($? != 0) then
- echo "Terminating..." >/dev/stderr
- exit 1
-Index: getopt-1.1.4/Makefile
-===================================================================
---- getopt-1.1.4.orig/Makefile
-+++ getopt-1.1.4/Makefile
-@@ -85,7 +85,7 @@ install_po: all_po
- for lang in $(LANGUAGES) ; do \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(INSTALL) -m 755 -d $(DESTDIR)$$dir ;\
-- $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt.mo ;\
-+ $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt-long.mo ;\
- done
- clean_po:
- $(RM) $(MOFILES)
-Index: getopt-1.1.4/nls.h
-===================================================================
---- getopt-1.1.4.orig/nls.h
-+++ getopt-1.1.4/nls.h
-@@ -29,7 +29,7 @@
- #ifndef GETOPT_NLS
- #define GETOPT_NLS
-
--#define PACKAGE "getopt"
-+#define PACKAGE "getopt-long"
-
- #ifndef WITHOUT_GETTEXT
- #include <libintl.h>
diff --git a/app-misc/getopt/files/getopt-1.1.5-longrename.patch b/app-misc/getopt/files/getopt-1.1.5-longrename.patch
deleted file mode 100644
index 03f2ca5a7445..000000000000
--- a/app-misc/getopt/files/getopt-1.1.5-longrename.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- getopt-1.1.5/getopt-parse.bash
-+++ getopt-1.1.5/getopt-parse.bash
-@@ -19,7 +19,7 @@
- # Note that we use `"$@"' to let each command-line parameter expand to a
- # separate word. The quotes around `$@' are essential!
- # We need TEMP as the `eval set --' would nuke the return value of getopt.
--TEMP=`getopt -o ab:c:: --long a-long,b-long:,c-long:: \
-+TEMP=`getopt-long -o ab:c:: --long a-long,b-long:,c-long:: \
- -n 'example.bash' -- "$@"`
-
- if [ $? != 0 ] ; then echo "Terminating..." >&2 ; exit 1 ; fi
---- getopt-1.1.5/getopt-parse.tcsh
-+++ getopt-1.1.5/getopt-parse.tcsh
-@@ -26,7 +26,7 @@
- # as a list. The ':q` copies that list without doing any substitutions:
- # each element of argv becomes a separate argument for getopt. The braces
- # are needed because the result is also a list.
--set temp=(`getopt -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
-+set temp=(`getopt-long -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
- if ($? != 0) then
- echo "Terminating..." >/dev/stderr
- exit 1
---- getopt-1.1.5/getopt.c
-+++ getopt-1.1.5/getopt.c
-@@ -320,10 +320,10 @@
-
- static void __attribute__ ((__noreturn__)) print_help(void)
- {
-- fputs(_("Usage: getopt optstring parameters\n"), stderr);
-- fputs(_(" getopt [options] [--] optstring parameters\n"), stderr);
-- fputs(_(" getopt [options] -o|--options optstring [options] [--]\n"), stderr);
-- fputs(_(" parameters\n"), stderr);
-+ fputs(_("Usage: getopt-long optstring parameters\n"), stderr);
-+ fputs(_(" getopt-long [options] [--] optstring parameters\n"), stderr);
-+ fputs(_(" getopt-long [options] -o|--options optstring [options] [--]\n"), stderr);
-+ fputs(_(" parameters\n"), stderr);
- fputs(_("\nOptions:\n"), stderr);
- fputs(_(" -a, --alternative Allow long options starting with single -\n"), stderr);
- fputs(_(" -h, --help This small usage guide\n"), stderr);
-@@ -333,7 +333,7 @@
- fputs(_(" -q, --quiet Disable error reporting by getopt(3)\n"), stderr);
- fputs(_(" -Q, --quiet-output No normal output\n"), stderr);
- fputs(_(" -s, --shell <shell> Set shell quoting conventions\n"), stderr);
-- fputs(_(" -T, --test Test for getopt(1) version\n"), stderr);
-+ fputs(_(" -T, --test Test for getopt-long(1) version\n"), stderr);
- fputs(_(" -u, --unquote Do not quote the output\n"), stderr);
- fputs(_(" -V, --version Output version information\n"), stderr);
- fputc('\n', stderr);
---- getopt-1.1.5/Makefile
-+++ getopt-1.1.5/Makefile
-@@ -32,7 +32,7 @@
- LANGUAGES = ca cs da de es et eu fi fr gl hu id it ja nl pl pt_BR ru sl sv tr uk vi zh_CN zh_TW
- MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
-
--CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)\" -Dprogram_version=\"$(VERSION)\"
-+CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)-long\" -Dprogram_version=\"$(VERSION)\"
- ifeq ($(LIBCGETOPT),0)
- CPPFLAGS+=-I./gnu
- endif
-@@ -81,7 +81,7 @@
- for lang in $(LANGUAGES) ; do \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(INSTALL) -m 755 -d $(DESTDIR)$$dir ;\
-- $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt.mo ;\
-+ $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt-long.mo ;\
- done
- clean_po:
- $(RM) $(MOFILES)
---- getopt-1.1.5/nls.h
-+++ getopt-1.1.5/nls.h
-@@ -29,7 +29,7 @@
- #ifndef GETOPT_NLS
- #define GETOPT_NLS
-
--#define PACKAGE "getopt"
-+#define PACKAGE "getopt-long"
-
- #if WITHOUT_GETTEXT
- #define _(Text) (Text)
diff --git a/app-misc/getopt/getopt-1.1.4.ebuild b/app-misc/getopt/getopt-1.1.4.ebuild
deleted file mode 100644
index c808b17962af..000000000000
--- a/app-misc/getopt/getopt-1.1.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=3
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="getopt(1) replacement supporting GNU-style long options"
-HOMEPAGE="http://software.frodo.looijaard.name/getopt/"
-SRC_URI="http://software.frodo.looijaard.name/getopt/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls"
-
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-libintl.patch"
- epatch "${FILESDIR}/${P}-longrename.patch"
-
- # hopefully this is portable enough
- epatch "${FILESDIR}"/${P}-irix.patch
-}
-
-src_compile() {
- local nogettext="1"
- local libintl=""
- local libcgetopt=1
-
- if use nls; then
- nogettext=0
- has_version sys-libs/glibc || libintl="-lintl"
- fi
-
- [[ ${CHOST} == *-irix* ]] && libcgetopt=0
- [[ ${CHOST} == *-interix* ]] && libcgetopt=0
-
- emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
- LIBCGETOPT=${libcgetopt} \
- WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
- CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- use nls && make prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
-
- into /usr
- newbin getopt getopt-long
-
- # at least on interix, the system getopt is ... broken...
- # util-linux, which would provide the getopt binary, does not build &
- # install on interix/prefix, so, this has to provide it.
- [[ ${CHOST} == *-interix* || ${CHOST} == *-mint* ]] && \
- dosym getopt-long /usr/bin/getopt
-
- newman getopt.1 getopt-long.1
-
- dodoc "${S}/getopt-"*sh
-}
diff --git a/app-misc/getopt/getopt-1.1.5.ebuild b/app-misc/getopt/getopt-1.1.5.ebuild
deleted file mode 100644
index 2bf8b781b433..000000000000
--- a/app-misc/getopt/getopt-1.1.5.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=3
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="getopt(1) replacement supporting GNU-style long options"
-HOMEPAGE="http://software.frodo.looijaard.name/getopt/"
-SRC_URI="http://software.frodo.looijaard.name/getopt/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls"
-
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libintl.patch
- epatch "${FILESDIR}"/${P}-setlocale.patch
- epatch "${FILESDIR}"/${P}-longrename.patch
-
- # hopefully this is portable enough
- epatch "${FILESDIR}"/${PN}-1.1.4-irix.patch
-}
-
-src_compile() {
- local nogettext="1"
- local libintl=""
- local libcgetopt=1
-
- if use nls; then
- nogettext=0
- has_version sys-libs/glibc || libintl="-lintl"
- fi
-
- [[ ${CHOST} == *-irix* ]] && libcgetopt=0
- [[ ${CHOST} == *-interix* ]] && libcgetopt=0
-
- emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
- LIBCGETOPT=${libcgetopt} \
- WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
- CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- use nls && make prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
-
- into /usr
- newbin getopt getopt-long
-
- # at least on interix, the system getopt is ... broken...
- # util-linux, which would provide the getopt binary, does not build &
- # install on interix/prefix, so, this has to provide it.
- [[ ${CHOST} == *-interix* || ${CHOST} == *-mint* ]] && \
- dosym getopt-long /usr/bin/getopt
-
- newman getopt.1 getopt-long.1
-
- dodoc "${S}/getopt-"*sh
-}