summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jdupes')
-rw-r--r--app-misc/jdupes/Manifest2
-rw-r--r--app-misc/jdupes/jdupes-1.27.3.ebuild (renamed from app-misc/jdupes/jdupes-1.21.3.ebuild)15
-rw-r--r--app-misc/jdupes/jdupes-9999.ebuild17
-rw-r--r--app-misc/jdupes/metadata.xml1
4 files changed, 22 insertions, 13 deletions
diff --git a/app-misc/jdupes/Manifest b/app-misc/jdupes/Manifest
index f35e6827e877..316a49a0e4a5 100644
--- a/app-misc/jdupes/Manifest
+++ b/app-misc/jdupes/Manifest
@@ -1 +1 @@
-DIST jdupes-1.21.3.tar.gz 155979 BLAKE2B b7d978aa8cc4574ce3a201e283a1cfccf6751689725f5307b78e47a9f1defd360d58be3ba2f558a6f40e7108a1ea4f0dd3c14d2332d14278c4114d303da3eea6 SHA512 22284adb1650dc44dfc74320799ac68e02e8d31685dd376d5f938d10308d117ae8af39273fbfec73f7e5a22e9685be96c92f0e12d9ebc81f11c255ada60abe83
+DIST jdupes-1.27.3.tar.gz 174779 BLAKE2B f6697df396e2f6e285d17465de183904f87e0b34b2a46bb7aeea6da8696ae31951af3f2f26b6e71cedbd25c756456ece055b99e76f92eadabd79a01183161d59 SHA512 ee2d60a922558e2aa819f9074fb0b3b38cc93ddc4f6ca3a1d0dd8731c4ecf72d1b6cbb0bc85be7cd63b21f7d9138efadfb64208122a4eebd4e55756a3edd5bcc
diff --git a/app-misc/jdupes/jdupes-1.21.3.ebuild b/app-misc/jdupes/jdupes-1.27.3.ebuild
index 73f625b27e25..b0ea5eb22c14 100644
--- a/app-misc/jdupes/jdupes-1.21.3.ebuild
+++ b/app-misc/jdupes/jdupes-1.27.3.ebuild
@@ -6,18 +6,24 @@ EAPI=8
inherit toolchain-funcs
DESCRIPTION="Identify duplicate files on the filesystem"
-HOMEPAGE="https://github.com/jbruchon/jdupes"
+HOMEPAGE="https://codeberg.org/jbruchon/jdupes"
if [[ "${PV}" == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ EGIT_REPO_URI="https://codeberg.org/jbruchon/jdupes.git"
inherit git-r3
else
- SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://codeberg.org/jbruchon/jdupes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
KEYWORDS="amd64"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="+dedupe lowmem hardened"
+# Please keep a careful eye on the minimum libjoycode version! (Just pick
+# latest released at the time if necessary.)
+DEPEND=">=dev-libs/libjodycode-3.0"
+RDEPEND="${DEPEND}"
+
+IUSE="+dedupe hardened"
# missing test.sh script
# https://github.com/jbruchon/jdupes/issues/191
@@ -32,7 +38,6 @@ src_compile() {
tc-export CC
local myconf=(
$(usex dedupe 'ENABLE_DEDUPE=1' '')
- $(usex lowmem 'LOW_MEMORY=1' '')
$(usex hardened 'HARDEN=1' '')
)
emake ${myconf[@]}
diff --git a/app-misc/jdupes/jdupes-9999.ebuild b/app-misc/jdupes/jdupes-9999.ebuild
index a6b6e30cf675..43ccea82ffe8 100644
--- a/app-misc/jdupes/jdupes-9999.ebuild
+++ b/app-misc/jdupes/jdupes-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,18 +6,24 @@ EAPI=8
inherit toolchain-funcs
DESCRIPTION="Identify duplicate files on the filesystem"
-HOMEPAGE="https://github.com/jbruchon/jdupes"
+HOMEPAGE="https://codeberg.org/jbruchon/jdupes"
if [[ "${PV}" == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ EGIT_REPO_URI="https://codeberg.org/jbruchon/jdupes.git"
inherit git-r3
else
- SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://codeberg.org/jbruchon/jdupes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
KEYWORDS="~amd64"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="+dedupe lowmem hardened"
+# Please keep a careful eye on the minimum libjoycode version! (Just pick
+# latest released at the time if necessary.)
+DEPEND=">=dev-libs/libjodycode-3.0"
+RDEPEND="${DEPEND}"
+
+IUSE="+dedupe hardened"
# missing test.sh script
# https://github.com/jbruchon/jdupes/issues/191
@@ -32,7 +38,6 @@ src_compile() {
tc-export CC
local myconf=(
$(usex dedupe 'ENABLE_DEDUPE=1' '')
- $(usex lowmem 'LOW_MEMORY=1' '')
$(usex hardened 'HARDEN=1' '')
)
emake ${myconf[@]}
diff --git a/app-misc/jdupes/metadata.xml b/app-misc/jdupes/metadata.xml
index 5079763f7636..61f7438c4a27 100644
--- a/app-misc/jdupes/metadata.xml
+++ b/app-misc/jdupes/metadata.xml
@@ -15,7 +15,6 @@
</maintainer>
<use>
<flag name="dedupe">Enable deduplication support</flag>
- <flag name="lowmem">Enable support for low-memory operation</flag>
</use>
<upstream>
<remote-id type="github">jbruchon/jdupes</remote-id>