summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jq')
-rw-r--r--app-misc/jq/Manifest4
-rw-r--r--app-misc/jq/files/jq-1.6-runpath.patch17
-rw-r--r--app-misc/jq/files/jq-1.6-segfault-fix.patch22
-rw-r--r--app-misc/jq/files/jq-1.7-visible-null.patch41
-rw-r--r--app-misc/jq/files/jq-1.7-warnings-r1.patch37
-rw-r--r--app-misc/jq/files/jq-1.7-warnings.patch44
-rw-r--r--app-misc/jq/files/jq-1.7_pre20201109-fix-configure-test.patch54
-rw-r--r--app-misc/jq/files/jq-1.7_pre20201109-no-git-bdep.patch13
-rw-r--r--app-misc/jq/jq-1.6-r3.ebuild78
-rw-r--r--app-misc/jq/jq-1.7.1.ebuild (renamed from app-misc/jq/jq-1.7_pre20201109-r1.ebuild)32
-rw-r--r--app-misc/jq/jq-1.7_pre20230210.ebuild92
-rw-r--r--app-misc/jq/metadata.xml2
12 files changed, 16 insertions, 420 deletions
diff --git a/app-misc/jq/Manifest b/app-misc/jq/Manifest
index 489984f6a2eb..cb0502875c76 100644
--- a/app-misc/jq/Manifest
+++ b/app-misc/jq/Manifest
@@ -1,3 +1 @@
-DIST jq-1.6.tar.gz 1750584 BLAKE2B c9be1314e9d027247de63492ee362e996ef85faf45a47ee421cad95ebde9188bff8d3fc7db64e717ab922e1052f3b1c1500f5589fc5b2199ab66effb000e442d SHA512 5da71f53c325257f1f546a2520fe47828b495c953270df25ea0e37741463fdda72f0ba4d5b05b25114ec30f27a559344c2b024bacabf610759f4e3e9efadb480
-DIST jq-1.7_pre20201109.tar.gz 1181867 BLAKE2B 9db187ab927b635c43fbc6191aeffa00451b12253ae023bbabe6fba5fdf8fb393f8450ee2011ef58cb93e2f27994d454fac967984a721439aaac93259c02f7f1 SHA512 f2997d70edb36d0a23b71a7d933a763cedd7c74ffa3129c2a6cb7189aaff1c5095cdc51062b7cd119324ec2c83ebae6ff0b7da3941315303b7a31146b9eb285a
-DIST jq-1.7_pre20230210.gh.tar.gz 1197799 BLAKE2B f4e90f78aa5afec88a4fc60f7a6f05f892647fcd9b59e67ea4727bb452eceead05b8cbe18b814d05665c5fadf8aaddc0cc9a06f2cb102c82503f857d0b70a485 SHA512 e7533c1dd53dad398c50b4cf37cef5d60f95eeee040d1c1ab776778fa14a093167500e1d99d71b22edc5f476079bad503c9c17f54fffefee0c5eb41b86bab406
+DIST jq-1.7.1.gh.tar.gz 1323338 BLAKE2B 17e3b68e23f9a7f1aa8749ede6c0b8fe435990899886f0c96da36d130c17d13609ba7f910321316f0c3b35985360f8cb5e6a3b12caea5e9bc7792e128798f137 SHA512 af9c444e5306423182f467a53acdf45bb8aefa058a47f490ce16395f0aebfb7627e3843f65e96f41cd9d4b72b8ad274ab0bdb061abc6990b1158f86d2256d4ec
diff --git a/app-misc/jq/files/jq-1.6-runpath.patch b/app-misc/jq/files/jq-1.6-runpath.patch
deleted file mode 100644
index 40a2ed02f3db..000000000000
--- a/app-misc/jq/files/jq-1.6-runpath.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 280694c..7227c9d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -280,4 +280,11 @@ AC_SUBST([BUNDLER], ["$bundle_cmd"])
- AC_CONFIG_MACRO_DIR([config/m4])
- AC_CONFIG_FILES([Makefile])
- AC_OUTPUT
--
-+AC_ARG_ENABLE([rpathhack],
-+ [AC_HELP_STRING([--enable-rpathhack], [patch libtool to remove RPATH])],
-+ [
-+AC_MSG_RESULT([patching libtool to fix rpath])
-+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
-+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
-+ ],
-+ [])
diff --git a/app-misc/jq/files/jq-1.6-segfault-fix.patch b/app-misc/jq/files/jq-1.6-segfault-fix.patch
deleted file mode 100644
index 8eb7d456bc6b..000000000000
--- a/app-misc/jq/files/jq-1.6-segfault-fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From a1f1231a73c221155d539a281181ef37f874869d Mon Sep 17 00:00:00 2001
-From: William Langford <wlangfor@gmail.com>
-Date: Tue, 20 Nov 2018 09:58:25 -0500
-Subject: [PATCH] Add missing jv_copy when printing with -ar
-
----
- src/main.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main.c b/src/main.c
-index b154689e..61ae43f9 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -168,7 +168,7 @@ static int process(jq_state *jq, jv value, int flags, int dumpopts) {
- while (jv_is_valid(result = jq_next(jq))) {
- if ((options & RAW_OUTPUT) && jv_get_kind(result) == JV_KIND_STRING) {
- if (options & ASCII_OUTPUT) {
-- jv_dumpf(result, stdout, JV_PRINT_ASCII);
-+ jv_dumpf(jv_copy(result), stdout, JV_PRINT_ASCII);
- } else {
- fwrite(jv_string_value(result), 1, jv_string_length_bytes(jv_copy(result)), stdout);
- }
diff --git a/app-misc/jq/files/jq-1.7-visible-null.patch b/app-misc/jq/files/jq-1.7-visible-null.patch
deleted file mode 100644
index 41e55df72111..000000000000
--- a/app-misc/jq/files/jq-1.7-visible-null.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff --git a/src/jv_print.c b/src/jv_print.c
-index 2e781bb..e621b31 100644
---- a/src/jv_print.c
-+++ b/src/jv_print.c
-@@ -32,7 +32,7 @@ static const jv_kind color_kinds[] =
- static char color_bufs[sizeof(color_kinds)/sizeof(color_kinds[0])][16];
- static const char *color_bufps[8];
- static const char* def_colors[] =
-- {COL("1;30"), COL("0;37"), COL("0;37"), COL("0;37"),
-+ {COL("1;90"), COL("0;37"), COL("0;37"), COL("0;37"),
- COL("0;32"), COL("1;37"), COL("1;37")};
- #define FIELD_COLOR COL("34;1")
-
-diff --git a/tests/shtest b/tests/shtest
-index 8ed62b2..2d3f0da 100755
---- a/tests/shtest
-+++ b/tests/shtest
-@@ -280,12 +280,12 @@ fi
-
- # Check $JQ_COLORS
- $JQ -Ccn . > $d/color
--printf '\033[1;30mnull\033[0m\n' > $d/expect
-+printf '\033[1;90mnull\033[0m\n' > $d/expect
- cmp $d/color $d/expect
- JQ_COLORS='4;31' $JQ -Ccn . > $d/color
- printf '\033[4;31mnull\033[0m\n' > $d/expect
- cmp $d/color $d/expect
--JQ_COLORS='1;30:0;31:0;32:0;33:0;34:1;35:1;36' \
-+JQ_COLORS='1;90:0;31:0;32:0;33:0;34:1;35:1;36' \
- $JQ -Ccn '[{"a":true,"b":false},123,null]' > $d/color
- (
- printf '\033[1;35m[\033[1;36m{'
-@@ -298,7 +298,7 @@ printf '[0m\033[0;31mfalse\033'
- printf '[0m\033[1;36m\033[1;36'
- printf 'm}\033[0m\033[1;35m,\033['
- printf '0;33m123\033[0m\033[1;'
--printf '35m,\033[1;30mnull\033'
-+printf '35m,\033[1;90mnull\033'
- printf '[0m\033[1;35m\033[1;35'
- printf 'm]\033[0m\n'
- ) > $d/expect
diff --git a/app-misc/jq/files/jq-1.7-warnings-r1.patch b/app-misc/jq/files/jq-1.7-warnings-r1.patch
deleted file mode 100644
index 4d0182493056..000000000000
--- a/app-misc/jq/files/jq-1.7-warnings-r1.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/src/builtin.c b/src/builtin.c
-index 1c6b08c..407df2a 100644
---- a/src/builtin.c
-+++ b/src/builtin.c
-@@ -1,5 +1,6 @@
- #define _BSD_SOURCE
- #define _GNU_SOURCE
-+#define _DEFAULT_SOURCE
- #ifndef __sun__
- # define _XOPEN_SOURCE
- # define _XOPEN_SOURCE_EXTENDED 1
-diff --git a/src/jv_dtoa.c b/src/jv_dtoa.c
-index 33feb99..fcbd902 100644
---- a/src/jv_dtoa.c
-+++ b/src/jv_dtoa.c
-@@ -2327,7 +2327,7 @@ retlow1:
- jvp_strtod
- (struct dtoa_context* C, const char *s00, char **se)
- {
-- int bb2, bb5, bbe, bd2, bd5, bbbits, bs2, c, e, e1, test_scale;
-+ int bb2, bb5, bbe, bd2, bd5, bbbits, bs2, c, e, e1;
- int esign, i, j, k, nd, nd0, nf, nz, nz0, nz1, sign;
- CONST char *s, *s0, *s1;
- double aadj, aadj1;
-diff --git a/src/jv_dtoa_tsd.c b/src/jv_dtoa_tsd.c
-index cfccd40..d39911e 100644
---- a/src/jv_dtoa_tsd.c
-+++ b/src/jv_dtoa_tsd.c
-@@ -31,7 +31,7 @@ void jv_tsd_dtoa_ctx_fini() {
- static
- #endif
- void jv_tsd_dtoa_ctx_init() {
-- if (pthread_key_create(&dtoa_ctx_key, tsd_dtoa_ctx_dtor) != 0) {
-+ if (pthread_key_create(&dtoa_ctx_key, (void (*)(void *))tsd_dtoa_ctx_dtor) != 0) {
- fprintf(stderr, "error: cannot create thread specific key");
- abort();
- }
diff --git a/app-misc/jq/files/jq-1.7-warnings.patch b/app-misc/jq/files/jq-1.7-warnings.patch
deleted file mode 100644
index 0047ca391cae..000000000000
--- a/app-misc/jq/files/jq-1.7-warnings.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/src/builtin.c b/src/builtin.c
-index bf80c7b..12db573 100644
---- a/src/builtin.c
-+++ b/src/builtin.c
-@@ -1,5 +1,6 @@
- #define _BSD_SOURCE
- #define _GNU_SOURCE
-+#define _DEFAULT_SOURCE
- #ifndef __sun__
- # define _XOPEN_SOURCE
- # define _XOPEN_SOURCE_EXTENDED 1
-diff --git a/src/jv_dtoa.c b/src/jv_dtoa.c
-index 33feb99..fcbd902 100644
---- a/src/jv_dtoa.c
-+++ b/src/jv_dtoa.c
-@@ -2327,7 +2327,7 @@ retlow1:
- jvp_strtod
- (struct dtoa_context* C, const char *s00, char **se)
- {
-- int bb2, bb5, bbe, bd2, bd5, bbbits, bs2, c, e, e1, test_scale;
-+ int bb2, bb5, bbe, bd2, bd5, bbbits, bs2, c, e, e1;
- int esign, i, j, k, nd, nd0, nf, nz, nz0, nz1, sign;
- CONST char *s, *s0, *s1;
- double aadj, aadj1;
-diff --git a/src/jv_dtoa_tsd.c b/src/jv_dtoa_tsd.c
-index 0f95df4..e5209dd 100644
---- a/src/jv_dtoa_tsd.c
-+++ b/src/jv_dtoa_tsd.c
-@@ -24,7 +24,7 @@ static void tsd_dtoa_ctx_fini() {
- }
-
- static void tsd_dtoa_ctx_init() {
-- if (pthread_key_create(&dtoa_ctx_key, tsd_dtoa_ctx_dtor) != 0) {
-+ if (pthread_key_create(&dtoa_ctx_key, (void (*)(void *))tsd_dtoa_ctx_dtor) != 0) {
- fprintf(stderr, "error: cannot create thread specific key");
- abort();
- }
-@@ -43,4 +43,4 @@ inline struct dtoa_context *tsd_dtoa_context_get() {
- }
- }
- return ctx;
--}
-\ No newline at end of file
-+}
diff --git a/app-misc/jq/files/jq-1.7_pre20201109-fix-configure-test.patch b/app-misc/jq/files/jq-1.7_pre20201109-fix-configure-test.patch
deleted file mode 100644
index 8be52042bcc4..000000000000
--- a/app-misc/jq/files/jq-1.7_pre20201109-fix-configure-test.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://github.com/stedolan/jq/pull/2480
-
-From 40bbd419ad8d1bd9cbe8b17063c323f8a40ab327 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 6 Sep 2022 09:59:31 -0700
-Subject: [PATCH 1/2] configure: Pass _XOPEN_SOURCE when checking for strptime
-
-Include sys/time.h for gettimeofday since thats where its in glibc
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
---- a/configure.ac
-+++ b/configure.ac
-@@ -139,7 +139,10 @@ AC_FUNC_ALLOCA
-
- AC_FIND_FUNC([isatty], [c], [#include <unistd.h>], [0])
- AC_FIND_FUNC([_isatty], [c], [#include <io.h>], [0])
-+OLD_CFLAGS=$CFLAGS
-+CFLAGS="$CFLAGS -D_XOPEN_SOURCE"
- AC_FIND_FUNC([strptime], [c], [#include <time.h>], [0, 0, 0])
-+CFLAGS=$OLD_CFLAGS
- AC_FIND_FUNC([strftime], [c], [#include <time.h>], [0, 0, 0, 0])
- AC_FIND_FUNC([setenv], [c], [#include <stdlib.h>], [0, 0, 0])
- AC_FIND_FUNC([timegm], [c], [#include <time.h>], [0])
-@@ -147,7 +150,7 @@ AC_FIND_FUNC([gmtime_r], [c], [#include <time.h>], [0, 0])
- AC_FIND_FUNC([gmtime], [c], [#include <time.h>], [0])
- AC_FIND_FUNC([localtime_r], [c], [#include <time.h>], [0, 0])
- AC_FIND_FUNC([localtime], [c], [#include <time.h>], [0])
--AC_FIND_FUNC([gettimeofday], [c], [#include <time.h>], [0, 0])
-+AC_FIND_FUNC([gettimeofday], [c], [#include <sys/time.h>], [0, 0])
- AC_CHECK_MEMBER([struct tm.tm_gmtoff], [AC_DEFINE([HAVE_TM_TM_GMT_OFF],1,[Define to 1 if the system has the tm_gmt_off field in struct tm])],
- [], [[#include <time.h>]])
- AC_CHECK_MEMBER([struct tm.__tm_gmtoff], [AC_DEFINE([HAVE_TM___TM_GMT_OFF],1,[Define to 1 if the system has the __tm_gmt_off field in struct tm])],
-
-From cda1734bed3b048c01452c798877d05b8c2f4c15 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 6 Sep 2022 10:00:59 -0700
-Subject: [PATCH 2/2] builtin: Replace _BSD_SOURCE with _DEFAULT_SOURCE
-
-newer glibc has remove _BSD_SOURCE and wants it to be replaced with _DEFAULT_SOURCE
-
-Fixes
-/usr/include/features.h:194:3: warning: "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-W#warnings]
-warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
---- a/src/builtin.c
-+++ b/src/builtin.c
-@@ -1,4 +1,4 @@
--#define _BSD_SOURCE
-+#define _DEFAULT_SOURCE
- #define _GNU_SOURCE
- #ifndef __sun__
- # define _XOPEN_SOURCE
-
diff --git a/app-misc/jq/files/jq-1.7_pre20201109-no-git-bdep.patch b/app-misc/jq/files/jq-1.7_pre20201109-no-git-bdep.patch
deleted file mode 100644
index 726624df13d6..000000000000
--- a/app-misc/jq/files/jq-1.7_pre20201109-no-git-bdep.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 0441d4a..592ceb9 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,8 +1,3 @@
--m4_define([jq_version],
-- m4_esyscmd_s([(git rev-parse --verify -q jq-1.0 > /dev/null &&
-- (git describe --tags --dirty --match 'jq-*'|sed 's/^jq-//')) ||
-- echo `git rev-parse --abbrev-ref HEAD`-`git describe --always --dirty`])))
--
- AC_INIT([jq], [jq_version], [https://github.com/stedolan/jq/issues],
- [jq], [https://stedolan.github.io/jq])
-
diff --git a/app-misc/jq/jq-1.6-r3.ebuild b/app-misc/jq/jq-1.6-r3.ebuild
deleted file mode 100644
index f1172ab62ab9..000000000000
--- a/app-misc/jq/jq-1.6-r3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="A lightweight and flexible command-line JSON processor"
-HOMEPAGE="https://stedolan.github.io/jq/"
-SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="MIT CC-BY-3.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x64-macos"
-IUSE="oniguruma static-libs"
-
-ONIGURUMA_MINPV='>=dev-libs/oniguruma-6.1.3' # Keep this in sync with bundled modules/oniguruma/
-DEPEND="
- >=sys-devel/bison-3.0
- sys-devel/flex
- oniguruma? ( ${ONIGURUMA_MINPV}:=[static-libs?] )
-"
-RDEPEND="
- !static-libs? (
- oniguruma? ( ${ONIGURUMA_MINPV}[static-libs?] )
- )
-"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/jq-1.6-r3-never-bundle-oniguruma.patch
- "${FILESDIR}"/jq-1.6-runpath.patch
- "${FILESDIR}"/jq-1.6-segfault-fix.patch
- )
- use oniguruma || { sed -i 's:tests/onigtest::' Makefile.am || die; }
- sed -i '/^dist_doc_DATA/d' Makefile.am || die
- sed -i -r "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
- configure.ac || die
-
- # jq-1.6-r3-never-bundle-oniguruma makes sure we build with the system oniguruma,
- # but the bundled copy of oniguruma still gets eautoreconf'd since it
- # exists; save the cycles by nuking it.
- sed -i -e '/modules\/oniguruma/d' Makefile.am || die
- rm -rf "${S}"/modules/oniguruma || die
-
- default
- eautoreconf
-}
-
-src_configure() {
- local econfargs=(
- # don't try to rebuild docs
- --disable-docs
- --disable-valgrind
- --disable-maintainer-mode
- --enable-rpathhack
- $(use_enable static-libs static)
- $(use_with oniguruma oniguruma yes)
- )
- econf "${econfargs[@]}"
-}
-
-src_test() {
- if ! emake check; then
- if [[ -r test-suite.log ]]; then
- eerror "Tests failed, outputting testsuite log"
- cat test-suite.log
- fi
- die "Tests failed"
- fi
-}
-
-src_install() {
- local DOCS=( AUTHORS README.md )
- default
-
- use static-libs || { find "${D}" -name '*.la' -delete || die; }
-}
diff --git a/app-misc/jq/jq-1.7_pre20201109-r1.ebuild b/app-misc/jq/jq-1.7.1.ebuild
index 6c0d7ed19c9b..81be3fadd8dc 100644
--- a/app-misc/jq/jq-1.7_pre20201109-r1.ebuild
+++ b/app-misc/jq/jq-1.7.1.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
-COMMIT_HASH="a17dd3248a666d01be75f6b16be37e80e20b0954"
-
+MY_PV="${PV/_/}"
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="A lightweight and flexible command-line JSON processor"
HOMEPAGE="https://stedolan.github.io/jq/"
-#SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
-SRC_URI="https://github.com/stedolan/jq/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+SRC_URI="https://github.com/jqlang/jq/archive/refs/tags/${MY_P}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
LICENSE="MIT CC-BY-3.0"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~arm64-macos ~x64-macos ~x64-solaris"
IUSE="+oniguruma static-libs test"
-ONIGURUMA_MINPV='>=dev-libs/oniguruma-6.1.3' # Keep this in sync with bundled modules/oniguruma/
+ONIGURUMA_MINPV='>=dev-libs/oniguruma-6.9.3' # Keep this in sync with bundled modules/oniguruma/
DEPEND="
>=sys-devel/bison-3.0
- sys-devel/flex
+ app-alternatives/lex
oniguruma? ( ${ONIGURUMA_MINPV}:=[static-libs?] )
"
RDEPEND="
@@ -32,11 +31,6 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/jq-1.6-r3-never-bundle-oniguruma.patch
"${FILESDIR}"/jq-1.7-runpath.patch
- "${FILESDIR}"/jq-1.7-warnings.patch
- "${FILESDIR}"/jq-1.7-visible-null.patch
- # https://bugs.gentoo.org/776385
- "${FILESDIR}"/jq-1.7_pre20201109-no-git-bdep.patch
- "${FILESDIR}"/jq-1.7_pre20201109-fix-configure-test.patch
)
RESTRICT="!test? ( test )"
@@ -44,8 +38,7 @@ REQUIRED_USE="test? ( oniguruma )"
src_prepare() {
sed -e '/^dist_doc_DATA/d; s:-Wextra ::' -i Makefile.am || die
- sed -r -e "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
- -i configure.ac || die
+ printf "#!/bin/sh\\nprintf '%s'\\n\n" "${MY_PV}" > scripts/version || die
# jq-1.6-r3-never-bundle-oniguruma makes sure we build with the system oniguruma,
# but the bundled copy of oniguruma still gets eautoreconf'd since it
@@ -54,6 +47,9 @@ src_prepare() {
rm -rf "${S}"/modules/oniguruma || die
default
+
+ sed -i "s/\[jq_version\]/[${MY_PV}]/" configure.ac || die
+
eautoreconf
}
@@ -81,7 +77,7 @@ src_test() {
}
src_install() {
- local DOCS=( AUTHORS NEWS README.md )
+ local DOCS=( AUTHORS NEWS.md README.md SECURITY.md )
default
use static-libs || { find "${D}" -name '*.la' -delete || die; }
diff --git a/app-misc/jq/jq-1.7_pre20230210.ebuild b/app-misc/jq/jq-1.7_pre20230210.ebuild
deleted file mode 100644
index 4143400bc2a8..000000000000
--- a/app-misc/jq/jq-1.7_pre20230210.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-COMMIT_HASH="cff5336ec71b6fee396a95bb0e4bea365e0cd1e8"
-
-DESCRIPTION="A lightweight and flexible command-line JSON processor"
-HOMEPAGE="https://stedolan.github.io/jq/"
-#SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
-SRC_URI="https://github.com/stedolan/jq/archive/${COMMIT_HASH}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT_HASH}"
-
-LICENSE="MIT CC-BY-3.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x64-macos"
-IUSE="+oniguruma static-libs test"
-
-ONIGURUMA_MINPV='>=dev-libs/oniguruma-6.1.3' # Keep this in sync with bundled modules/oniguruma/
-DEPEND="
- >=sys-devel/bison-3.0
- sys-devel/flex
- oniguruma? ( ${ONIGURUMA_MINPV}:=[static-libs?] )
-"
-RDEPEND="
- !static-libs? (
- oniguruma? ( ${ONIGURUMA_MINPV}[static-libs?] )
- )
-"
-PATCHES=(
- "${FILESDIR}"/jq-1.6-r3-never-bundle-oniguruma.patch
- "${FILESDIR}"/jq-1.7-runpath.patch
- "${FILESDIR}"/jq-1.7-warnings-r1.patch
- "${FILESDIR}"/jq-1.7-visible-null.patch
- # https://bugs.gentoo.org/776385
- "${FILESDIR}"/jq-1.7_pre20201109-no-git-bdep.patch
- "${FILESDIR}"/jq-1.7_pre20201109-fix-configure-test.patch
-)
-
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( oniguruma )"
-
-src_prepare() {
- sed -e '/^dist_doc_DATA/d; s:-Wextra ::' -i Makefile.am || die
- sed -r -e "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
- -i configure.ac || die
-
- # jq-1.6-r3-never-bundle-oniguruma makes sure we build with the system oniguruma,
- # but the bundled copy of oniguruma still gets eautoreconf'd since it
- # exists; save the cycles by nuking it.
- sed -e '/modules\/oniguruma/d' -i Makefile.am || die
- rm -rf "${S}"/modules/oniguruma || die
- sed -i "s/^jq_version: .*/jq_version: \"${PV}\"/" docs/site.yml || die
-
- default
-
- sed -i "s/\[jq_version\]/[${PV}]/" configure.ac || die
-
- eautoreconf
-}
-
-src_configure() {
- local econfargs=(
- # don't try to rebuild docs
- --disable-docs
- --disable-valgrind
- --disable-maintainer-mode
- --enable-rpathhack
- $(use_enable static-libs static)
- $(use_with oniguruma oniguruma yes)
- )
- econf "${econfargs[@]}"
-}
-
-src_test() {
- if ! LD_LIBRARY_PATH="${S}/.libs" nonfatal emake check; then
- if [[ -r "${S}/test-suite.log" ]]; then
- eerror "Tests failed, outputting testsuite log"
- cat "${S}/test-suite.log"
- fi
- die "Tests failed"
- fi
-}
-
-src_install() {
- local DOCS=( AUTHORS NEWS README.md )
- default
-
- use static-libs || { find "${D}" -name '*.la' -delete || die; }
-}
diff --git a/app-misc/jq/metadata.xml b/app-misc/jq/metadata.xml
index aa4e2e57a5ad..c62cb69977a6 100644
--- a/app-misc/jq/metadata.xml
+++ b/app-misc/jq/metadata.xml
@@ -14,6 +14,6 @@
</use>
<upstream>
<remote-id type="cpe">cpe:/a:jq_project:jq</remote-id>
- <remote-id type="github">stedolan/jq</remote-id>
+ <remote-id type="github">jqlang/jq</remote-id>
</upstream>
</pkgmetadata>