summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/kanatest/kanatest-0.4.8.ebuild')
-rw-r--r--app-misc/kanatest/kanatest-0.4.8.ebuild48
1 files changed, 19 insertions, 29 deletions
diff --git a/app-misc/kanatest/kanatest-0.4.8.ebuild b/app-misc/kanatest/kanatest-0.4.8.ebuild
index d24f05ecee86..c1d64fbe9eb8 100644
--- a/app-misc/kanatest/kanatest-0.4.8.ebuild
+++ b/app-misc/kanatest/kanatest-0.4.8.ebuild
@@ -1,48 +1,38 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools epatch gnome2-utils
+inherit autotools xdg
DESCRIPTION="Visual flashcard tool for memorizing the Japanese Hiragana and Katakana alphabet"
-HOMEPAGE="http://www.clayo.org/kanatest"
-SRC_URI="http://www.clayo.org/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.clayo.org/kanatest"
+SRC_URI="https://www.clayo.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2 GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-RDEPEND=">=x11-libs/gtk+-2.12:2=
+RDEPEND="
+ x11-libs/gtk+:2
dev-libs/libxml2:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DOCS=( AUTHORS TRANSLATORS ChangeLog README )
+PATCHES=(
+ "${FILESDIR}"/${P}+gtk-2.22.patch
+ "${FILESDIR}"/${P}-autoconf.patch
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-desktop-QA.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}+gtk-2.22.patch \
- "${FILESDIR}"/${P}-autoconf.patch \
- "${FILESDIR}"/${P}-cflags.patch
-
- sed -i \
- -e '/Encoding/d' \
- -e '/^Categories/s:Application;::' \
- -e '/^Icon/s:.png::' \
- data/${PN}.desktop || die
-
+ default
eautoreconf
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
+src_install() {
+ default
+ dodoc TRANSLATORS
}