summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r3.ebuild')
-rw-r--r--app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r3.ebuild b/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r3.ebuild
index 59dfb7d11bf7..206c1cc0e6dc 100644
--- a/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r3.ebuild
+++ b/app-misc/kryoflux-dtc/kryoflux-dtc-2.6-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,9 +16,9 @@ SRC_URI="
"
S="${WORKDIR}/${MY_P}"
-KEYWORDS="-* amd64 x86"
LICENSE="SPS"
SLOT="0"
+KEYWORDS="-* amd64 x86"
IUSE="demos doc fast-firmware gui static"
RDEPEND="
@@ -94,6 +94,8 @@ pkg_postinst() {
elog "If you want to access your Kryoflux without root access,"
elog "please add yourself to the floppy group."
+ udev_reload
+
if use fast-firmware; then
elog ""
elog "You have enabled the fast firmware. Please keep in mind,"
@@ -105,3 +107,12 @@ pkg_postinst() {
xdg_mimeinfo_database_update
fi
}
+
+pkg_postrm() {
+ udev_reload
+
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}