summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild')
-rw-r--r--app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild b/app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild
new file mode 100644
index 000000000000..4daf115a5902
--- /dev/null
+++ b/app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Programs to safely lock/unlock files and mailboxes"
+HOMEPAGE="http://packages.debian.org/sid/lockfile-progs"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND="net-libs/liblockfile"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Provide better Makefile, with clear separation between compilation
+ # and installation.
+ cp "${FILESDIR}/Makefile" . || die
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ # Makefile has no notion of PREFIX, bindir, and the like
+ emake DESTDIR="${ED}" install || die
+}