summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/logitech-applet/logitech-applet-0.4_pre1-r3.ebuild')
-rw-r--r--app-misc/logitech-applet/logitech-applet-0.4_pre1-r3.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-misc/logitech-applet/logitech-applet-0.4_pre1-r3.ebuild b/app-misc/logitech-applet/logitech-applet-0.4_pre1-r3.ebuild
index 4c2d5534f1aa..ed10f90c5788 100644
--- a/app-misc/logitech-applet/logitech-applet-0.4_pre1-r3.ebuild
+++ b/app-misc/logitech-applet/logitech-applet-0.4_pre1-r3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch
+EAPI=7
+
+inherit autotools
MY_P=${P/_pre/test}
MY_P=${MY_P/-applet/_applet}
@@ -10,6 +11,7 @@ MY_P=${MY_P/-applet/_applet}
DESCRIPTION="Control utility for some special features of some special Logitech USB mice!"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
@@ -18,10 +20,18 @@ KEYWORDS="amd64 x86"
DEPEND="virtual/libusb:0"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${P}-mx300-mx518.patch
+ "${FILESDIR}"/${PN}-0.4_pre1-configure-error-handling.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-mx300-mx518.patch
+ default
+
+ mv configure.{in,ac} || die
+
+ # For error handling patch
+ eautoreconf
}
src_install() {