summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mkcert/mkcert-1.4.4.ebuild')
-rw-r--r--app-misc/mkcert/mkcert-1.4.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/mkcert/mkcert-1.4.4.ebuild b/app-misc/mkcert/mkcert-1.4.4.ebuild
new file mode 100644
index 000000000000..b013677509ec
--- /dev/null
+++ b/app-misc/mkcert/mkcert-1.4.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A zero-config tool to make locally trusted development certificates"
+HOMEPAGE="https://github.com/FiloSottile/mkcert"
+SRC_URI="https://github.com/FiloSottile/mkcert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+src_compile() {
+ ego build -tags release -ldflags "-X main.Version=${PV}" -o ${PN}
+}
+
+src_install() {
+ dobin mkcert
+ dodoc README.md
+}