summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/no-more-secrets/no-more-secrets-9999.ebuild')
-rw-r--r--app-misc/no-more-secrets/no-more-secrets-9999.ebuild33
1 files changed, 11 insertions, 22 deletions
diff --git a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
index d5955c438a05..6fcda186cfdf 100644
--- a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
+++ b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
@@ -1,40 +1,29 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
-#if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/bartobri/${PN}.git"
- SRC_URI=""
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/bartobri/no-more-secrets.git"
inherit git-r3
- KEYWORDS=""
-#else
-# SRC_URI=""
-# KEYWORDS=""
-#fi
+else
+ SRC_URI="https://github.com/bartobri/no-more-secrets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
-DESCRIPTION="recreate decrypting text from 1992 movie 'Sneakers'"
+DESCRIPTION="Recreate decrypting text from 1992 movie 'Sneakers'"
HOMEPAGE="https://github.com/bartobri/no-more-secrets"
LICENSE="GPL-3"
SLOT=0
DEPEND="sys-libs/ncurses:0="
-
RDEPEND="${DEPEND}"
-src_prepare() {
- sed -i 's#CC =#CC ?=#' Makefile
- sed -i 's#prefix =#prefix ?=#' Makefile
- sed -i 's#CFLAGS =#CFLAGS ?=#' Makefile
-}
+PATCHES=( "${FILESDIR}"/no-more-secrets-9999-2018-10-25-respect-ldflags.patch )
src_compile() {
- CC=$(tc-getCC) CFLAGS=${CFLAGS} emake
-}
-
-src_install() {
- prefix=/usr DESTDIR="${ED}" emake install
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
}