summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb-plugin-effects')
-rw-r--r--app-misc/openrgb-plugin-effects/Manifest3
-rw-r--r--app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-dep.patch15
-rw-r--r--app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-qrc.patch11
-rw-r--r--app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0.8.ebuild66
4 files changed, 95 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-effects/Manifest b/app-misc/openrgb-plugin-effects/Manifest
index e5b66a3a5b73..559acba296d3 100644
--- a/app-misc/openrgb-plugin-effects/Manifest
+++ b/app-misc/openrgb-plugin-effects/Manifest
@@ -1 +1,4 @@
DIST OpenRGBEffectsPlugin-a7222bdbcd3c52e13d96993a33c5648f1306aeba.tar.bz2 255129 BLAKE2B 8fc7ee994d80bd9fe8d8a76e26710ed0fec429aa8df835f6a46a64d4034a4fc2352d722c9aed26032bff33781b1f024a893d685f6883e1816872d91cd937c1d0 SHA512 386879a7a1f05cfcbcca792add1b18f2680b4fa7b139f8532e6f32d09a5194c381357d3cbb3883352c2a03280c9b0b0f1e9faef7e140c7535144c0d645832d3e
+DIST OpenRGBEffectsPlugin-release_0.8.tar.bz2 232858 BLAKE2B 71851eaa40719d8b04a91577756e76b248d261c344e461a00f2c60d26fe37b2a1a2d563a67f620a4c6887d21d4505cb715850f6f0eb4f133894833a72f22e8e4 SHA512 c1ad3f460a9cb4788e9eae3f6df1f0b60a838205a0655c1a639f1bcd04c00f99d55d9a51161267e543bbd961883d4ae0751babe7c98d9be395f104ac9d40e8e3
+DIST QCodeEditor-2021-08-17.tar.gz 95099 BLAKE2B d9eab343c956288b098c9fad4b523615beb7c1a860a00b8c84a2a71f40398fd2e82c335c5d82bb5bc2d15d35bad698a780ff4d1d3202f7555a93120e8a2d906a SHA512 4f8af3a45d3b16d06bc6e4b795f005cf917a80add8f738454751a47d40747df1215ba9b4e05a0f654251bc006521151f8a256c2e41be05c72abae4e55f383b54
+DIST SimplexNoise-2019-12-03.tar.gz 781353 BLAKE2B ce05f78b58439d57e369b8b3944b8d392bec80d579767cb1683befe5c56b90dcf40d405ff75d4541e6c17659f6e1abc83f5d3444fbe641724d21ed509e439854 SHA512 b1e27d6630a902006636ec31c3b1cead1857b255edc8ae8db74cdfee25300337200be48264c6adc0e2c0e39a3693e361d448e61ae62d2f0b700374b264d5e5cd
diff --git a/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-dep.patch b/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-dep.patch
new file mode 100644
index 000000000000..b01adb4ac7d1
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-dep.patch
@@ -0,0 +1,15 @@
+Fix dependency on app-misc/openrgb
+
+--- a/OpenRGBEffectsPlugin.pro
++++ b/OpenRGBEffectsPlugin.pro
+@@ -60,10 +60,6 @@ HEADERS +=
+ OpenRGB/qt/hsv.h \
+
+
+-SOURCES += \
+- OpenRGB/RGBController/RGBController.cpp \
+- OpenRGB/dependencies/ColorWheel/ColorWheel.cpp \
+- OpenRGB/qt/hsv.cpp \
+
+
+ #-----------------------------------------------------------------------------------------------#
diff --git a/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-qrc.patch b/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-qrc.patch
new file mode 100644
index 000000000000..87919c542d7f
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0.8-qrc.patch
@@ -0,0 +1,11 @@
+Because of -Wl,--export-dynamic in app-misc/openrgb, this resources.qrc
+conflicts with the openrgb's one. So rename it.
+
+--- a/OpenRGBEffectsPlugin.pro
++++ b/OpenRGBEffectsPlugin.pro
+@@ -472,4 +472,4 @@ macx: {
+ }
+
+ RESOURCES += \
+- resources.qrc
++ resources_effects_plugin.qrc
diff --git a/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0.8.ebuild b/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0.8.ebuild
new file mode 100644
index 000000000000..98722bf8b3f7
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Plugin for OpenRGB with various Effects that can be synced across devices"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin"
+
+MY_NOISE_COMMIT="97e62c5b5e26c8edabdc29a6b0a277192be3746c"
+MY_QCODEEDITOR_COMMIT="a9aab24c7970a38d14bc79939306d9d3ba78cf61"
+SRC_URI="
+ https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin/-/archive/release_${PV}/OpenRGBEffectsPlugin-release_${PV}.tar.bz2
+ https://github.com/SRombauts/SimplexNoise/archive/${MY_NOISE_COMMIT}.tar.gz -> SimplexNoise-2019-12-03.tar.gz
+ https://github.com/justxi/QCodeEditor/archive/${MY_QCODEEDITOR_COMMIT}.tar.gz -> QCodeEditor-2021-08-17.tar.gz
+"
+S="${WORKDIR}/OpenRGBEffectsPlugin-release_${PV}"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-misc/openrgb-0.7:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ media-libs/openal
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/openrgb-plugin-effects-0.8-dep.patch"
+ "${FILESDIR}/openrgb-plugin-effects-0.8-qrc.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+
+ rmdir Dependencies/SimplexNoise || die
+ ln -s "${WORKDIR}/SimplexNoise-${MY_NOISE_COMMIT}" Dependencies/SimplexNoise || die
+
+ rmdir Dependencies/QCodeEditor || die
+ ln -s "${WORKDIR}/QCodeEditor-${MY_QCODEEDITOR_COMMIT}" Dependencies/QCodeEditor || die
+
+ # Because of -Wl,--export-dynamic in app-misc/openrgb, this resources.qrc
+ # conflicts with the openrgb's one. So rename it.
+ mv --no-clobber resources.qrc resources_effects_plugin.qrc || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBEffectsPlugin.so.1.0
+}