summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/Manifest2
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.5-build-system.patch13
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.8-includes.patch24
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.9-build-system.patch12
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.9-udev-check.patch12
-rw-r--r--app-misc/openrgb/files/openrgb-0.8-gcc-13.patch36
-rw-r--r--app-misc/openrgb/openrgb-0.9.ebuild (renamed from app-misc/openrgb/openrgb-0.8-r1.ebuild)15
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild18
8 files changed, 44 insertions, 88 deletions
diff --git a/app-misc/openrgb/Manifest b/app-misc/openrgb/Manifest
index e0ff770dc389..f543fecc55fd 100644
--- a/app-misc/openrgb/Manifest
+++ b/app-misc/openrgb/Manifest
@@ -1 +1 @@
-DIST OpenRGB-release_0.8.tar.bz2 28631365 BLAKE2B 3b328e38f1c52646da02b0b2b2c22b1285f3b31b0a2bc684e99d491d04bd14a91b49bc196b3b81b537320cd872e5568aaa8aec34744f4f15392d9424a81ac6f0 SHA512 d69686da7cab33099b13cfb5ab876fc2db047f79aa01bf8150507ec41321b4c6c092f81623823b89916c70a1a24c4a102f77b1001c5caa721ff4c0c52e0630d2
+DIST OpenRGB-release_0.9.tar.bz2 28689813 BLAKE2B 9fcf08d5e4d07ffc0f7867516f09044e18ce488bcdd99c8b44e0afe291b8a21a7ba92d6e7fd683ef22462a262004a992621efb59a5df6ed7551f4e9f75843241 SHA512 fb1bdbc7bcbd3bac888be313cfb6403a13d39de659ac6993858f9c1b17ad40e9c4a7d4c7c90682181841db1659a0ee298363c442a7120d43347aaf4485e7dccf
diff --git a/app-misc/openrgb/files/OpenRGB-0.5-build-system.patch b/app-misc/openrgb/files/OpenRGB-0.5-build-system.patch
deleted file mode 100644
index fe805988af5d..000000000000
--- a/app-misc/openrgb/files/OpenRGB-0.5-build-system.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/OpenRGB.pro b/OpenRGB.pro
-index 91e0079..7f279dd 100644
---- a/OpenRGB.pro
-+++ b/OpenRGB.pro
-@@ -26,8 +26,5 @@ TEMPLATE = app
- win32:BUILDDATE = $$system(date /t)
- unix:BUILDDATE = $$system(date -R -d "@${SOURCE_DATE_EPOCH:-$(date +%s)}")
--GIT_COMMIT_ID = $$system(git --git-dir $$_PRO_FILE_PWD_/.git --work-tree $$_PRO_FILE_PWD_ rev-parse HEAD)
--GIT_COMMIT_DATE = $$system(git --git-dir $$_PRO_FILE_PWD_/.git --work-tree $$_PRO_FILE_PWD_ show -s --format=%ci HEAD)
--GIT_BRANCH = $$system(git --git-dir $$_PRO_FILE_PWD_/.git --work-tree $$_PRO_FILE_PWD_ rev-parse --abbrev-ref HEAD)
-
- DEFINES += \
- VERSION_STRING=\\"\"\"$$VERSION\\"\"\" \
diff --git a/app-misc/openrgb/files/OpenRGB-0.8-includes.patch b/app-misc/openrgb/files/OpenRGB-0.8-includes.patch
deleted file mode 100644
index 8ed341b06029..000000000000
--- a/app-misc/openrgb/files/OpenRGB-0.8-includes.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 8c893fba4fcec17e6221f2d754def4aa71b020b8 Mon Sep 17 00:00:00 2001
-From: Sirn Thanabulpong <sirn@ogsite.net>
-Date: Wed, 28 Dec 2022 00:49:47 +0900
-Subject: [PATCH] Fix build on musl in Nanoleaf settings
-
----
- qt/OpenRGBNanoleafSettingsPage/OpenRGBNanoleafScanningThread.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/qt/OpenRGBNanoleafSettingsPage/OpenRGBNanoleafScanningThread.cpp b/qt/OpenRGBNanoleafSettingsPage/OpenRGBNanoleafScanningThread.cpp
-index 1e3c926b3..55ed5fcaa 100644
---- a/qt/OpenRGBNanoleafSettingsPage/OpenRGBNanoleafScanningThread.cpp
-+++ b/qt/OpenRGBNanoleafSettingsPage/OpenRGBNanoleafScanningThread.cpp
-@@ -8,6 +8,7 @@
- #else
- #include <netdb.h>
- #include <ifaddrs.h>
-+#include <sys/select.h>
- #endif
-
- #include "mdns.h"
---
-GitLab
-
diff --git a/app-misc/openrgb/files/OpenRGB-0.9-build-system.patch b/app-misc/openrgb/files/OpenRGB-0.9-build-system.patch
new file mode 100644
index 000000000000..567e60787b72
--- /dev/null
+++ b/app-misc/openrgb/files/OpenRGB-0.9-build-system.patch
@@ -0,0 +1,12 @@
+--- a/OpenRGB.pro
++++ b/OpenRGB.pro
+@@ -46,9 +46,6 @@ TEMPLATE = app
+ #-----------------------------------------------------------------------------------------------#
+ win32:BUILDDATE = $$system(date /t)
+ unix:BUILDDATE = $$system(date -R -d "@${SOURCE_DATE_EPOCH:-$(date +%s)}")
+-GIT_COMMIT_ID = $$system(git log -n 1 --pretty=format:"%H")
+-GIT_COMMIT_DATE = $$system(git log -n 1 --pretty=format:"%ci")
+-GIT_BRANCH = $$system(git branch --show-current)
+
+ DEFINES += \
+ VERSION_STRING=\\"\"\"$$VERSION\\"\"\" \
diff --git a/app-misc/openrgb/files/OpenRGB-0.9-udev-check.patch b/app-misc/openrgb/files/OpenRGB-0.9-udev-check.patch
new file mode 100644
index 000000000000..e3525c116baf
--- /dev/null
+++ b/app-misc/openrgb/files/OpenRGB-0.9-udev-check.patch
@@ -0,0 +1,12 @@
+We install udev to /lib/udev instead, which it doesn't check
+
+--- a/ResourceManager.cpp
++++ b/ResourceManager.cpp
+@@ -895,7 +895,6 @@ void ResourceManager::DetectDevicesThreadFunction()
+ {
+ if(access("/usr/lib/udev/rules.d/60-openrgb.rules", F_OK) != 0)
+ {
+- udev_not_exist = true;
+ }
+ }
+ else
diff --git a/app-misc/openrgb/files/openrgb-0.8-gcc-13.patch b/app-misc/openrgb/files/openrgb-0.8-gcc-13.patch
deleted file mode 100644
index 2a78d8f4ab5c..000000000000
--- a/app-misc/openrgb/files/openrgb-0.8-gcc-13.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
-index 2bdc37ad695dfdc870cb912f17fffd54bda2b89b..17080edb896f74c9393049041c25347d38a8a6f5 100644
---- a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
-+++ b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
-@@ -10,6 +10,7 @@
- #include "ENESMBusInterface_SpectrixS40G.h"
- #include <sys/ioctl.h>
- #include <cstring>
-+#include <cstdint>
-
- /*---------------------------------------------------------------------*\
- | Functions for submitting NVME admin passthrough command taken from |
-diff --git a/Controllers/SteelSeriesController/SteelSeriesMouseController.h b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
-index 64df7a1cc0351ccb8f306984c8b554f8eb3dcc6e..a4e561a3504c1def8acdd1921dc3955df7f68271 100644
---- a/Controllers/SteelSeriesController/SteelSeriesMouseController.h
-+++ b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
-@@ -10,6 +10,7 @@
- #include <hidapi/hidapi.h>
- #include <vector>
- #include "SteelSeriesGeneric.h"
-+#include <cstdint>
-
- #pragma once
-
-diff --git a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
-index 8f0cd4cdb637ea5f474b1caf587dc3c98c5dba89..367e9175b07548845696616aef86920ca2536bb4 100644
---- a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
-+++ b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
-@@ -11,6 +11,7 @@
- #include <cstring>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <cstdint>
-
- static void send_usb_msg(hid_device* dev, char * data_pkt, unsigned int size)
- {
diff --git a/app-misc/openrgb/openrgb-0.8-r1.ebuild b/app-misc/openrgb/openrgb-0.9.ebuild
index d80c05c700e6..9c15691b3b6b 100644
--- a/app-misc/openrgb/openrgb-0.8-r1.ebuild
+++ b/app-misc/openrgb/openrgb-0.9.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev xdg-utils
+inherit check-reqs flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -12,7 +12,7 @@ else
SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGB-release_${PV}"
KEYWORDS="amd64 ~loong ~x86"
- PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.9-build-system.patch )
fi
DESCRIPTION="Open source RGB lighting control"
@@ -20,7 +20,7 @@ HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
# subslot is OPENRGB_PLUGIN_API_VERSION from
# https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
-SLOT="0/2"
+SLOT="0/3"
RDEPEND="
dev-cpp/cpp-httplib:=
@@ -42,11 +42,12 @@ BDEPEND="
"
PATCHES+=(
- "${FILESDIR}"/${PN}-0.8-gcc-13.patch
"${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
- "${FILESDIR}"/OpenRGB-0.8-includes.patch
+ "${FILESDIR}"/OpenRGB-0.9-udev-check.patch
)
+CHECKREQS_DISK_BUILD="2G"
+
src_prepare() {
default
rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
@@ -55,8 +56,8 @@ src_prepare() {
src_configure() {
# Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
+ # The upstream build system of plugins bundles OpenRGB as a submodule
+ # instead, and compiles the .cpp file again.
append-ldflags -Wl,--export-dynamic
# > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 291cae9fb808..9fdf9377f299 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev xdg-utils
+inherit check-reqs flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -12,14 +12,15 @@ else
SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGB-release_${PV}"
KEYWORDS="~amd64 ~loong ~x86"
- PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.9-build-system.patch )
fi
DESCRIPTION="Open source RGB lighting control"
HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
-# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
-SLOT="0/2"
+# subslot is OPENRGB_PLUGIN_API_VERSION from
+# https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
+SLOT="0/3"
RDEPEND="
dev-cpp/cpp-httplib:=
@@ -42,8 +43,11 @@ BDEPEND="
PATCHES+=(
"${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
+ "${FILESDIR}"/OpenRGB-0.9-udev-check.patch
)
+CHECKREQS_DISK_BUILD="2G"
+
src_prepare() {
default
rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
@@ -52,8 +56,8 @@ src_prepare() {
src_configure() {
# Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
+ # The upstream build system of plugins bundles OpenRGB as a submodule
+ # instead, and compiles the .cpp file again.
append-ldflags -Wl,--export-dynamic
# > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
@@ -70,8 +74,8 @@ src_install() {
dodoc README.md OpenRGB.patch
- udev_dorules 60-openrgb.rules
rm -r "${ED}"/usr/lib/udev/ || die
+ udev_dorules 60-openrgb.rules
# This is for plugins. Upstream doesn't install any headers at all.
insinto /usr/include/OpenRGB