summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pax-utils/pax-utils-1.0.2.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-1.0.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/app-misc/pax-utils/pax-utils-1.0.2.ebuild b/app-misc/pax-utils/pax-utils-1.0.2.ebuild
deleted file mode 100644
index f253ed0df5ec..000000000000
--- a/app-misc/pax-utils/pax-utils-1.0.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils toolchain-funcs unpacker
-
-DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
-HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
-SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
- https://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
- https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="caps python"
-
-RDEPEND="caps? ( sys-libs/libcap )
- python? ( dev-python/pyelftools )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-
-_emake() {
- emake \
- USE_CAP=$(usex caps) \
- USE_PYTHON=$(usex python) \
- "$@"
-}
-
-src_configure() {
- # Avoid slow configure+gnulib+make if on an up-to-date Linux system
- if use prefix || ! use kernel_linux || \
- has_version '<sys-libs/glibc-2.10'
- then
- econf $(use_with caps) $(use_with python)
- else
- tc-export CC
- fi
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake check
-}
-
-src_install() {
- _emake DESTDIR="${ED}" PKGDOCDIR='$(DOCDIR)'/${PF} install
-}