summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pipeworks')
-rw-r--r--app-misc/pipeworks/files/pipeworks-0.4-makefile.patch26
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r2.ebuild (renamed from app-misc/pipeworks/pipeworks-0.4-r1.ebuild)12
2 files changed, 31 insertions, 7 deletions
diff --git a/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
new file mode 100644
index 000000000000..8a52d158b0e4
--- /dev/null
+++ b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,21 +18,11 @@
+ # along with pipeworks; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-CC= gcc -Wall
++CFLAGS += -Wall
+
+ all: pipeworks
+
+-filesize.o: Makefile filesize.h filesize.c
+- $(CC) -c -o filesize.o filesize.c
+-
+-timemanip.o: Makefile timemanip.h timemanip.c
+- $(CC) -c -o timemanip.o timemanip.c
+-
+-pipeworks.o: Makefile pipeworks.c filesize.h
+- $(CC) -c -o pipeworks.o pipeworks.c
+-
+-pipeworks: pipeworks.o filesize.o timemanip.o
+- $(CC) -o pipeworks pipeworks.o filesize.o timemanip.o
++pipeworks: filesize.o timemanip.o
+
+ clean:
+ rm -f *.o *~ pipeworks
diff --git a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
index 28c0a7a154e0..bcef6fb41379 100644
--- a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
+++ b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,13 +12,11 @@ SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {