summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/qtxdg-tools/qtxdg-tools-3.10.0.ebuild')
-rw-r--r--app-misc/qtxdg-tools/qtxdg-tools-3.10.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/qtxdg-tools/qtxdg-tools-3.10.0.ebuild b/app-misc/qtxdg-tools/qtxdg-tools-3.10.0.ebuild
new file mode 100644
index 000000000000..29bc5043c278
--- /dev/null
+++ b/app-misc/qtxdg-tools/qtxdg-tools-3.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="User Tools from libqtxdg"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.12.0"
+RDEPEND="
+ >=dev-libs/libqtxdg-3.10.0
+ >=dev-qt/qtcore-5.15:5
+"
+DEPEND="${RDEPEND}"