summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/realpath/files')
-rw-r--r--app-misc/realpath/files/realpath-1.14-no-po4a.patch12
-rw-r--r--app-misc/realpath/files/realpath-1.15-prefix.patch37
-rw-r--r--app-misc/realpath/files/realpath-1.16-nonls.patch24
-rw-r--r--app-misc/realpath/files/realpath-1.17-build.patch43
4 files changed, 0 insertions, 116 deletions
diff --git a/app-misc/realpath/files/realpath-1.14-no-po4a.patch b/app-misc/realpath/files/realpath-1.14-no-po4a.patch
deleted file mode 100644
index 44e13286bfac..000000000000
--- a/app-misc/realpath/files/realpath-1.14-no-po4a.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Don't require po4a at build time.
-http://bugs.gentoo.org/269905
-
---- a/po/Makefile
-+++ b/po/Makefile
-@@ -4,5 +4,5 @@
- #
-
- ALL_TARGET=
--SUBDIRS=bin man
-+SUBDIRS=bin
- include ../common.mk
diff --git a/app-misc/realpath/files/realpath-1.15-prefix.patch b/app-misc/realpath/files/realpath-1.15-prefix.patch
deleted file mode 100644
index 3e0837a8bf38..000000000000
--- a/app-misc/realpath/files/realpath-1.15-prefix.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/common.mk
-+++ b/common.mk
-@@ -8,17 +8,19 @@ override TOPDIR := $(dir $(call getCurrentMakefileName))
-
- override PACKAGE := realpath
-
--PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
-+#PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
-+
-+SHELL := @GENTOO_PORTAGE_EPREFIX@/bin/bash
-
- # build abstraction
--install_file := install -p -o root -g root -m 644
--install_script := install -p -o root -g root -m 755
--install_dir := install -d -o root -g root -m 755
-+install_file := install -p -m 644
-+install_script := install -p -m 755
-+install_dir := install -d -m 755
- install_link := ln -sf
- compress := gzip -9f
-
--prefix := /usr
--etcdir := /etc/$(PACKAGE)
-+prefix := @GENTOO_PORTAGE_EPREFIX@/usr
-+etcdir := @GENTOO_PORTAGE_EPREFIX@/etc/$(PACKAGE)
- bindir := $(prefix)/bin
- sbindir := $(prefix)/sbin
- mandir := $(prefix)/share/man
-@@ -33,7 +35,7 @@ webdocrootdir := /var/www
- webcgidir := $(prefix)/lib/cgi-bin
- applicationsdir := $(prefix)/share/applications
-
--PERL := /usr/bin/perl
-+PERL := @GENTOO_PORTAGE_EPREFIX@/usr/bin/perl
- CC ?= gcc
- CFLAGS += -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
- LDFLAGS +=
diff --git a/app-misc/realpath/files/realpath-1.16-nonls.patch b/app-misc/realpath/files/realpath-1.16-nonls.patch
deleted file mode 100644
index c1963ae46014..000000000000
--- a/app-misc/realpath/files/realpath-1.16-nonls.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/src/realpath.c
-+++ b/src/realpath.c
-@@ -23,10 +23,9 @@
- #include <errno.h>
- #include <getopt.h>
- #include <stdarg.h>
--#include <libintl.h>
- #include <locale.h>
-
--#define _(String) gettext (String)
-+#define _(String) (String)
-
- static char *stripdir(char * dir, char *buf, int maxlen);
-
-@@ -116,9 +115,6 @@ int main(int argc, char **argv) {
-
- myname = ( p = strchr(argv[0], '/') ) ? p+1 : argv[0];
-
-- setlocale(LC_ALL, "");
-- bindtextdomain(PACKAGE, LOCALEDIR);
-- textdomain(PACKAGE);
-
-
- parse_options(argc, argv);
diff --git a/app-misc/realpath/files/realpath-1.17-build.patch b/app-misc/realpath/files/realpath-1.17-build.patch
deleted file mode 100644
index c4a8b3dfc9b9..000000000000
--- a/app-misc/realpath/files/realpath-1.17-build.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/common.mk
-+++ b/common.mk
-@@ -33,16 +33,9 @@
- applicationsdir := $(prefix)/share/applications
-
- PERL := /usr/bin/perl
--CC := gcc
--CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
--LIBS :=
--
--ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-- CFLAGS += -O0
--else
-- CFLAGS += -O2
--endif
--
-+CC ?= gcc
-+CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
-+LIBS +=
-
- # determine our version number
- ifndef VERSION
-@@ -58,9 +51,6 @@
- unexport CDPATH ENV
-
- ifdef DESTDIR
-- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
-- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
-- endif
- override ddirshort := DESTDIR
- export ddirshort
- endif
-@@ -108,7 +99,9 @@
- esac; fi;
- endef
- else
-- msg := :
-+ define msg
-+ :
-+ endef
- endif
-
- msgprefix := *$(subst * ,*,$(wordlist 1,$(MAKELEVEL),* * * * * * * * * * * * * * * * * *))