summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/recoll')
-rw-r--r--app-misc/recoll/Manifest3
-rw-r--r--app-misc/recoll/recoll-1.36.2.ebuild (renamed from app-misc/recoll/recoll-1.34.6-r1.ebuild)6
-rw-r--r--app-misc/recoll/recoll-1.37.4-r1.ebuild131
-rw-r--r--app-misc/recoll/recoll-1.37.4.ebuild129
4 files changed, 265 insertions, 4 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index ebd2f7783c23..4ad5f8ef7ae9 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1 +1,2 @@
-DIST recoll-1.34.6.tar.gz 3078366 BLAKE2B 91ae9e72851b008da61e41a1ddd5091b20b3e683506970e01f39eb2e3b5dfc174ebbc213ef29daede601322b21783ea34e34e04992447375015189c8fdec9d71 SHA512 f151a8f3575af41277fc9b50bb9a5e2ea1348e035b3dead36b47d1d6918deb755a4d59913d174db48273afdd95f4a063aa20219f1116a6d83c82fb063dbf16b7
+DIST recoll-1.36.2.tar.gz 3129206 BLAKE2B 0631d8c88f56f3381dd899fa385cba84a720d9d3a49b19b9b344de9542d79e3e5d5e10008fd7dd098795df2a4c79a682ff9a10ff4f99243fa2f7abd99831b553 SHA512 4c7ce5b6f6213ba4cb9266dcd6ea26e56850aa984c343552464766c5036ac6fd2ac6e9e71157997e10e8ba0350d23a4ebc3f2d57978805aa2d33674aa2a6c8b0
+DIST recoll-1.37.4.tar.gz 3135691 BLAKE2B 1c9113cbccb812e522addbc7fec0aa0b958d8616aa1b753aa866e9bb96f78dc0a40bb79a4a8ad016286f2508f1d8dea172d308917a430fa4c98822feaba0d309 SHA512 9e5af5d00191658f23e6a5916718014827f12f4553d9429fe385c0bd1c72f2f49ae97e7d7b8121cb174b299ffe482aa547e4a3aabf2da92e9773bf9eb0f57814
diff --git a/app-misc/recoll/recoll-1.34.6-r1.ebuild b/app-misc/recoll/recoll-1.36.2.ebuild
index 0abee2ec2760..8984ef8682eb 100644
--- a/app-misc/recoll/recoll-1.34.6-r1.ebuild
+++ b/app-misc/recoll/recoll-1.36.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit linux-info optfeature python-single-r1 qmake-utils systemd
@@ -13,7 +13,7 @@ SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
REQUIRED_USE="
@@ -119,7 +119,7 @@ pkg_postinst() {
optfeature "iCalendar files support" dev-python/icalendar
optfeature "Postscript files support" app-text/pstotext
optfeature "RTF files support" app-text/unrtf
- optfeature "TeX files support" dev-text/detex
+ optfeature "TeX files support" virtual/tex-base
optfeature "DVI files support" virtual/tex-base
optfeature "DJVU files support" app-text/djvu
optfeature "tags in audio files support" media-libs/mutagen
diff --git a/app-misc/recoll/recoll-1.37.4-r1.ebuild b/app-misc/recoll/recoll-1.37.4-r1.ebuild
new file mode 100644
index 000000000000..23842e87356d
--- /dev/null
+++ b/app-misc/recoll/recoll-1.37.4-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils systemd
+
+DESCRIPTION="Personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ systemd? ( sys-apps/systemd )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable spell python-aspell)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ $(use_with systemd)
+ --with-system-unit-dir="$(systemd_get_systemunitdir)"
+ --with-user-unit-dir="$(systemd_get_userunitdir)"
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+ use qt5 && myeconfargs+=( $(usex webengine "--disable-webpreview" "--enable-webpreview" ) )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
+ rm -rf "${D}/$(python_get_sitedir)"/*.egg-info || die
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" virtual/tex-base
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}
diff --git a/app-misc/recoll/recoll-1.37.4.ebuild b/app-misc/recoll/recoll-1.37.4.ebuild
new file mode 100644
index 000000000000..422dbf52adef
--- /dev/null
+++ b/app-misc/recoll/recoll-1.37.4.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils systemd
+
+DESCRIPTION="Personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ systemd? ( sys-apps/systemd )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable spell python-aspell)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ $(use_with systemd)
+ --with-system-unit-dir="$(systemd_get_systemunitdir)"
+ --with-user-unit-dir="$(systemd_get_userunitdir)"
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+ use qt5 && myeconfargs+=( $(usex webengine "--disable-webpreview" "--enable-webpreview" ) )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" virtual/tex-base
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}