summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild')
-rw-r--r--app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild b/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..f0f186a0fc5e
--- /dev/null
+++ b/app-misc/regex-markup/regex-markup-0.10.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A tool to color syslog files as well"
+HOMEPAGE="http://www.nongnu.org/regex-markup/"
+SRC_URI="http://savannah.nongnu.org/download/regex-markup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples nls"
+
+PATCHES=(
+ "${FILESDIR}/${P}-locale.patch"
+)
+
+src_configure() {
+ # fix #570960 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ econf \
+ --enable-largefile \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ if use examples; then
+ cd examples || die
+ emake -f Makefile
+ fi
+}