summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch')
-rw-r--r--app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch40
1 files changed, 18 insertions, 22 deletions
diff --git a/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch b/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
index 85252867a692..6fbda6197eef 100644
--- a/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
+++ b/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
@@ -1,30 +1,26 @@
https://bugs.gentoo.org/903657
https://github.com/tmate-io/tmate/pull/281
-
-From a5c6e80d3c54cd7faed52de5283b4f96bea86c13 Mon Sep 17 00:00:00 2001
-From: Carlo Cabrera <30379873+carlocab@users.noreply.github.com>
-Date: Sun, 5 Mar 2023 20:58:13 +0800
-Subject: [PATCH] Fix finding msgpack 6+
-
-`msgpack.pc` was renamed to `msgpack-c.pc` upstream in msgpack/msgpack-c#1053.
--- a/configure.ac
+++ b/configure.ac
-@@ -209,6 +209,17 @@ PKG_CHECK_MODULES(
+@@ -207,7 +207,20 @@ PKG_CHECK_MODULES(
+ LIBS="$MSGPACK_LIBS $LIBS"
+ found_msgpack=yes
],
- found_msgpack=no
- )
-+# msgpack.pc was renamed to msgpack-c.pc in 6.0.0.
-+PKG_CHECK_MODULES(
-+ MSGPACKC,
-+ msgpack-c >= 1.1.0,
+- found_msgpack=no
+ [
-+ CPPFLAGS="$MSGPACKC_CFLAGS $CPPFLAGS"
-+ LIBS="$MSGPACKC_LIBS $LIBS"
-+ found_msgpack=yes
-+ ],
-+ found_msgpack=no
-+)
++ found_msgpack=no
++ # msgpack.pc was renamed to msgpack-c.pc in 6.0.0.
++ PKG_CHECK_MODULES(
++ MSGPACKC,
++ msgpack-c >= 1.1.0,
++ [
++ CPPFLAGS="$MSGPACKC_CFLAGS $CPPFLAGS"
++ LIBS="$MSGPACKC_LIBS $LIBS"
++ found_msgpack=yes
++ ],
++ found_msgpack=no
++ )
++ ]
+ )
if test "x$found_msgpack" = xno; then
AC_MSG_ERROR("msgpack >= 1.1.0 not found")
- fi
-