summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmux/tmux-1.9a-r2.ebuild')
-rw-r--r--app-misc/tmux/tmux-1.9a-r2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-1.9a-r2.ebuild b/app-misc/tmux/tmux-1.9a-r2.ebuild
new file mode 100644
index 000000000000..7fd1b5454752
--- /dev/null
+++ b/app-misc/tmux/tmux-1.9a-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug selinux vim-syntax"
+
+COMMON_DEPEND="
+ =dev-libs/libevent-2.0*
+ sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ README TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.9a"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
+ ewarn "older, running tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to access them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ # regenerate aclocal.m4 to support earlier automake versions
+ rm aclocal.m4 || die
+
+ # remove generated files
+ rm -r compat/.{dirstamp,deps} || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}