summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/towitoko')
-rw-r--r--app-misc/towitoko/Manifest1
-rw-r--r--app-misc/towitoko/metadata.xml11
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r2.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/towitoko/Manifest b/app-misc/towitoko/Manifest
new file mode 100644
index 000000000000..5fb37fdb9676
--- /dev/null
+++ b/app-misc/towitoko/Manifest
@@ -0,0 +1 @@
+DIST towitoko-2.0.7.tar.gz 280177 SHA256 28f36954b5225dbb1729728fadaa723f49e141c5a4b77dc75d9558d787c8e660 SHA512 e2e21bda3b1dad55dee1cfb4063e114394a21973b4b2409b9dcff1479fc312fb93bf6e634d38e1f7a30e6f835d87af8268a478b534f65c916eeb13d5dbd07b86 WHIRLPOOL d3ff6aaa3c33570389ebef6d1d0648d55ea1653227e5fb0128a48f11dec5b3d42f7b9e46bdcee7c45f038c0acff66b67fe9d33ed9c7c5f8ed380e2a8a128fd19
diff --git a/app-misc/towitoko/metadata.xml b/app-misc/towitoko/metadata.xml
new file mode 100644
index 000000000000..2bda83b020a2
--- /dev/null
+++ b/app-misc/towitoko/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='moneyplex'>Makes libtowitoko work for the moneyplex home banking
+ software</flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/towitoko/towitoko-2.0.7-r2.ebuild b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..0a2c0f45ddee
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE="moneyplex"
+
+DESCRIPTION="This library provides a driver for using Towitoko smartcard readers under UNIX environment"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://www.gentoo.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+src_compile() {
+ local myconf
+
+ myconf=""
+ use moneyplex && myconf="${myconf} --disable-atr-check"
+
+ econf \
+ $(use_enable moneyplex win32-com) \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if ! use moneyplex
+ then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}