summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/when')
-rw-r--r--app-misc/when/Manifest1
-rw-r--r--app-misc/when/metadata.xml3
-rw-r--r--app-misc/when/when-1.1.45.ebuild43
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/when/Manifest b/app-misc/when/Manifest
index ce8a5159a7c2..5b6b6bf20a05 100644
--- a/app-misc/when/Manifest
+++ b/app-misc/when/Manifest
@@ -1 +1,2 @@
DIST when-1.1.40.tar.gz 55306 BLAKE2B 3d4bdc962ccff64b09f5dda7a2c7be1daa0fd5fed2039f784ea6279e9aac495823159098f6a05c281de40d7964cc244a76c6b3bda1c4227748c04c98effac54d SHA512 0d70f2c9c4d44bbd922dc0d6b1a4e1eb90561a81add3ad4f1e1fc467a6331ca856d66725361d4e5ea3f1ce9ea1ed59d91ad18178e022b029c04c0c15747ecbcd
+DIST when-1.1.45.tar.gz 46424 BLAKE2B 5c4d7036d2b5e5db6af3fa611411d11a1952eb8316861a9da90edc75d08e439349a46c4b86ec2c5a43276eb04240c03f59a80224ece8def7b84fee6e0c84ef95 SHA512 918265ae64d06f02dd358c48596e9fab422c5de884f9bf12684d857c50790c5e4977d68040e51c0dfc39c7a4d66b76ba2fa88b620bc96024f89c5be2ab4846fd
diff --git a/app-misc/when/metadata.xml b/app-misc/when/metadata.xml
index 9ce966571c31..5e5fade75398 100644
--- a/app-misc/when/metadata.xml
+++ b/app-misc/when/metadata.xml
@@ -6,4 +6,7 @@
<name>Gentoo Shell Tools Project</name>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="bitbucket">ben-crowell/when</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/when/when-1.1.45.ebuild b/app-misc/when/when-1.1.45.ebuild
new file mode 100644
index 000000000000..6567ca7148e9
--- /dev/null
+++ b/app-misc/when/when-1.1.45.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vcs-snapshot
+
+DESCRIPTION="Minimalistic personal calendar program"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html https://bitbucket.org/ben-crowell/when"
+SRC_URI="https://bitbucket.org/ben-crowell/${PN}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake when.1
+}
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when || die 'mkdir failed'
+ touch "${HOME}"/.when/{calendar,preferences} || die 'touch failed'
+ emake test
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}