summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wildq/wildq-1.1.10.ebuild')
-rw-r--r--app-misc/wildq/wildq-1.1.10.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/app-misc/wildq/wildq-1.1.10.ebuild b/app-misc/wildq/wildq-1.1.10.ebuild
deleted file mode 100644
index ccc4444aac82..000000000000
--- a/app-misc/wildq/wildq-1.1.10.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Command-line TOML/JSON/INI/YAML/XML processor using jq c bindings"
-HOMEPAGE="https://pypi.org/project/wildq/ https://github.com/ahmet2mir/wildq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="hcl toml xml"
-RDEPEND="
- dev-python/jq[${PYTHON_USEDEP}]
- hcl? ( dev-python/pyhcl[${PYTHON_USEDEP}] )
- toml? ( dev-python/toml[${PYTHON_USEDEP}] )
- xml? ( dev-python/xmltodict[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- # Unpin install_requires versions.
- sed -e "s|^\\([ []'[[:alnum:]]\+\\)>=[^']*|\\1|" -i setup.py || die
- distutils-r1_python_prepare_all
-}