summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ytree/ytree-2.03.ebuild')
-rw-r--r--app-misc/ytree/ytree-2.03.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/ytree/ytree-2.03.ebuild b/app-misc/ytree/ytree-2.03.ebuild
new file mode 100644
index 000000000000..719e4443d480
--- /dev/null
+++ b/app-misc/ytree/ytree-2.03.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based file manager"
+HOMEPAGE="https://www.han.de/~werner/ytree.html"
+SRC_URI="https://www.han.de/~werner/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README THANKS ytree.conf )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+ doman ${PN}.1
+}