summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.4.1.ebuild40
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild4
3 files changed, 43 insertions, 2 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index e8ab3d1c4f4a..fdd9fbae0916 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1 +1,2 @@
DIST binwalk-2.4.0.tar.gz 39744574 BLAKE2B 8503e86afb584e431b25611fbed91e85aaf307e9011b5ef09a83b5f4756a815f9d3de67d440a2b7547cbe162d1940e8d6ffc4899afac14ccb938304002b1eb41 SHA512 41bee6a0d1cd587f81dcf81c30215a305b61e4db208bc9d8e4f0b9f12acb47e4dc2e6af23e06118ef6e30c484f6be743b456b6d4324be4388413ff291682345e
+DIST binwalk-2.4.1.tar.gz 39747760 BLAKE2B 480f8ff06932c77ca5ab2857cddf7ecebb36b6f2e55e3ccf15a971fa0f4c59d57b652556fd9f0dd20e6fbd887fdef3c6da022f76787b2edf16b0d1714d291e8a SHA512 f83d0ca09a39033944ce16345b7c2c8f3051a20f80315e4c797221df4e6844c7c89c0a49053d739156e2654b482d6ef93f0814fa588daab031dbeaed1423e6f2
diff --git a/app-misc/binwalk/binwalk-2.4.1.ebuild b/app-misc/binwalk/binwalk-2.4.1.ebuild
new file mode 100644
index 000000000000..e628cb990f4e
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/OSPG/binwalk.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/OSPG/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/OSPG/binwalk"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "entropy graph" dev-python/matplotlib
+ optfeature "disassembly" dev-libs/capstone[python]
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many more optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index 53c023e8014b..e628cb990f4e 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 optfeature
@@ -34,7 +34,7 @@ pkg_postinst() {
optfeature "disassembly" dev-libs/capstone[python]
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "binwalk has many optional dependencies to automatically"
+ elog "binwalk has many more optional dependencies to automatically"
elog "extract/decompress data, see INSTALL.md for more details."
fi
}