summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/no-more-secrets/Manifest1
-rw-r--r--app-misc/no-more-secrets/no-more-secrets-0.3.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/no-more-secrets/Manifest b/app-misc/no-more-secrets/Manifest
new file mode 100644
index 000000000000..7806d7d107b8
--- /dev/null
+++ b/app-misc/no-more-secrets/Manifest
@@ -0,0 +1 @@
+DIST no-more-secrets-0.3.3.tar.gz 24713 BLAKE2B c47cc71e72c8bc10bfc27b382e22d1b808b1efa65f3355ce0b435490c1628e476824414541fd12c58c99b47822724bb8cb6cdf1a0b0edf05068e7400cfcef09a SHA512 d261c9d2f7617149815627a4b6817aa5b483045cefbad148038ac9f13bc231b571034791aaaabc2ce9ab112cecc6015efc74167955099b8b57d1810f81210b31
diff --git a/app-misc/no-more-secrets/no-more-secrets-0.3.3.ebuild b/app-misc/no-more-secrets/no-more-secrets-0.3.3.ebuild
new file mode 100644
index 000000000000..57fdd08f5c3e
--- /dev/null
+++ b/app-misc/no-more-secrets/no-more-secrets-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+SRC_URI="https://github.com/bartobri/no-more-secrets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+DESCRIPTION="Recreate decrypting text from 1992 movie 'Sneakers'"
+HOMEPAGE="https://github.com/bartobri/no-more-secrets"
+LICENSE="GPL-3"
+SLOT=0
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's#CC =#CC ?=#' \
+ -e 's#prefix =#prefix ?=#' \
+ -e 's#CFLAGS =#CFLAGS ?=#' Makefile || die
+ default
+}
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" emake
+}
+
+src_install() {
+ prefix="/usr" DESTDIR="${ED}" emake install
+}