summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lcdproc/Manifest2
-rw-r--r--app-misc/lcdproc/files/LCDd.initd15
-rw-r--r--app-misc/lcdproc/files/LCDd.service10
-rw-r--r--app-misc/lcdproc/files/lcdexec.initd16
-rw-r--r--app-misc/lcdproc/files/lcdexec.service10
-rw-r--r--app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch16
-rw-r--r--app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch15
-rw-r--r--app-misc/lcdproc/files/lcdproc.initd16
-rw-r--r--app-misc/lcdproc/files/lcdproc.service10
-rw-r--r--app-misc/lcdproc/lcdproc-0.5.9.ebuild211
-rw-r--r--app-misc/lcdproc/metadata.xml43
11 files changed, 349 insertions, 15 deletions
diff --git a/app-misc/lcdproc/Manifest b/app-misc/lcdproc/Manifest
index 9e2a404d0525..ad948bc7e9e5 100644
--- a/app-misc/lcdproc/Manifest
+++ b/app-misc/lcdproc/Manifest
@@ -2,3 +2,5 @@ DIST lcdproc-0.5.2-patches.tar.gz 6571 BLAKE2B 11cc34b39ceed329ba1aa9d0750a5c90d
DIST lcdproc-0.5.2.tar.gz 822695 BLAKE2B f7065c2d6ee1c6305d3682166bb2b4920a9f0ac2a079b57389f76edf75c81fa9ebe954358b216dbad866e2daa10f95857106e125cc54a9207a98553f408ae77b SHA512 e21a1f2d3d5f53aa09477e9aea1f9685c1fe224a8f79f15d0d032214de211c51619a9eea9183743c024859349d481fe35d7999cc51e0de81dc2fa8e0c85d7a5d
DIST lcdproc-0.5.5.tar.gz 946206 BLAKE2B eb9e1248e84d4c9352a39991a1125e74cbfee9094d19a75da4298811120fcf2ef8fef056b35873b6308af79f92eb9187e504f43c4b28c07ca402de2c5d8fdc97 SHA512 42500188adb018547db4db4a472dded478a03f19974843865e07a466870fbca409b4259b57366b7dfdd4a5fd444a89c1930032d1127ae036128dbd9279a24b29
DIST lcdproc-0.5.6.tar.gz 998996 BLAKE2B 022ce656390caea0c9394ca7a5458f7285e2655f53c49f6fa7d9f94c0638f9f97cc70af66bb779a6b7ca8024b70c2865d51719b72918a4a7da3f6af7d4451976 SHA512 7c506b4691c8544855dadf939863672230c3e0903bbe4bbde82df04ff932f818cdc406c5b159554ec155d0c46fff23d435121298f4e19bac73658b121c6b8220
+DIST lcdproc-0.5.9.tar.gz 1091292 BLAKE2B 10b26fc803cf14bf301177336bd14497131440f129d16fa75cbb4782da839eb3a3835091d7c211cfc75d35f07823a1c301cf7ebfae25f2a344d0dfcaf894ca17 SHA512 48e11a587570376b9524591f4c23deace9ac1609b83ba9e17f2a4e950d5598f8f88b580ca01c174ec9c2ef98b1eef7ac274c23ca3541d4d7ff918af0598c6a25
+DIST linux_input.docbook 1764 BLAKE2B 8e82173d0169e2e79f2625b7bd572409b10fff1ac1a6ebd59527887e3568aad2aa459bb225d95af5e7b2a24b23671d8e7b3a78fdadc7a70e2fe33a36129bed32 SHA512 9b0579713c6d084fa9e0adee6c04387a3f91375f2cbcf2c7e47c01238df07e355330ebeb98081fd296279980fa808e4943c958772891559731465a9e75436ec0
diff --git a/app-misc/lcdproc/files/LCDd.initd b/app-misc/lcdproc/files/LCDd.initd
new file mode 100644
index 000000000000..792ae9201796
--- /dev/null
+++ b/app-misc/lcdproc/files/LCDd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+instance="${SVCNAME}"
+name="LCDProc (${instance})"
+pidfile="/run/${instance}.pid"
+
+command="/usr/sbin/LCDd"
+command_args="-c /etc/${instance}.conf"
+
+depend() {
+ use g15daemon
+ use net
+}
diff --git a/app-misc/lcdproc/files/LCDd.service b/app-misc/lcdproc/files/LCDd.service
new file mode 100644
index 000000000000..bd53c8cae3cb
--- /dev/null
+++ b/app-misc/lcdproc/files/LCDd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LCDProc (LCDd)
+After=network-online.target
+
+[Service]
+ExecStart=/usr/sbin/LCDd -c /etc/LCDd.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/lcdproc/files/lcdexec.initd b/app-misc/lcdproc/files/lcdexec.initd
new file mode 100644
index 000000000000..b349ae972d83
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdexec.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+instance="${SVCNAME}"
+name="LCDProc (${instance})"
+pidfile="/run/${instance}.pid"
+
+command="/usr/bin/lcdexec"
+command_args="-c /etc/${instance}.conf"
+
+depend() {
+ after ntp-client
+ use LCDd
+ use net
+}
diff --git a/app-misc/lcdproc/files/lcdexec.service b/app-misc/lcdproc/files/lcdexec.service
new file mode 100644
index 000000000000..56ec3dd64cb1
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdexec.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LCDProc (LCDd)
+After=network-online.target
+
+[Service]
+ExecStart=/usr/bin/lcdexec -c /etc/lcdexec.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch b/app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch
new file mode 100644
index 000000000000..763038d14ab5
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch
@@ -0,0 +1,16 @@
+--- a/server/drivers/Makefile.am 2017-01-22 23:18:54.000000000 +0100
++++ b/server/drivers/Makefile.am 2018-10-04 22:48:50.302344274 +0200
+@@ -47,11 +47,11 @@
+ futaba_LDADD = @LIBUSB_LIBS@ @LIBUSB_1_0_LIBS@ libLCD.a
+ g15_LDADD = @LIBG15@
+ glcd_LDADD = libLCD.a @GLCD_DRIVERS@ @FT2_LIBS@ @LIBPNG_LIBS@ @LIBSERDISP@ @LIBUSB_LIBS@ @LIBX11_LIBS@
+-glcd_DEPENDENCIES = @GLCD_DRIVERS@ glcd-glcd-render.o
++glcd_DEPENDENCIES = @GLCD_DRIVERS@ glcd-glcd-render.o libLCD.a
+ glcdlib_LDADD = @LIBGLCD@
+ glk_LDADD = libbignum.a
+ hd44780_LDADD = libLCD.a @HD44780_DRIVERS@ @HD44780_I2C@ @LIBUSB_LIBS@ @LIBFTDI_LIBS@ @LIBUGPIO@ libbignum.a
+-hd44780_DEPENDENCIES = @HD44780_DRIVERS@ @HD44780_I2C@
++hd44780_DEPENDENCIES = @HD44780_DRIVERS@ @HD44780_I2C@ libLCD.a libbignum.a
+ i2500vfd_LDADD = @LIBFTDI_LIBS@
+ imon_LDADD = libLCD.a libbignum.a
+ imonlcd_LDADD = libLCD.a
diff --git a/app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch b/app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch
new file mode 100644
index 000000000000..9149bf784276
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac 2017-06-18 22:33:56.000000000 +0200
++++ b/configure.ac 2018-10-04 22:30:22.668770478 +0200
+@@ -389,11 +389,7 @@
+ AC_MSG_RESULT($enable_freetype)
+
+ if test "$enable_freetype" = "yes"; then
+- ifdef([AC_CHECK_FT2],
+- [AC_CHECK_FT2([],
+- [AC_DEFINE(HAVE_FT2, [1], [Define to 1 if you have freetype])],
+- [enable_freetype=no])],
+- [AC_MSG_WARN([freetype does not seem to be installed])])
++ PKG_CHECK_MODULES(FT2, freetype2 >= 7.0.1, [enable_freetype="yes"],[enable_freetype="no"])
+ fi
+ AC_SUBST([FT2_CFLAGS])
+ AC_SUBST([FT2_LIBS])
diff --git a/app-misc/lcdproc/files/lcdproc.initd b/app-misc/lcdproc/files/lcdproc.initd
new file mode 100644
index 000000000000..bbeba4033c02
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+instance="${SVCNAME}"
+name="LCDProc (${instance})"
+pidfile="/run/${instance}.pid"
+
+command="/usr/bin/lcdproc"
+command_args="-c /etc/${instance}.conf"
+
+depend() {
+ after ntp-client
+ use LCDd
+ use net
+}
diff --git a/app-misc/lcdproc/files/lcdproc.service b/app-misc/lcdproc/files/lcdproc.service
new file mode 100644
index 000000000000..f2ee435a169b
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LCDProc (LCDd)
+After=network-online.target
+
+[Service]
+ExecStart=/usr/bin/lcdproc -c /etc/lcdproc.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/lcdproc/lcdproc-0.5.9.ebuild b/app-misc/lcdproc/lcdproc-0.5.9.ebuild
new file mode 100644
index 000000000000..a8eb7fee247f
--- /dev/null
+++ b/app-misc/lcdproc/lcdproc-0.5.9.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools systemd
+
+DESCRIPTION="Displays real-time system information from your Linux/*BSD box on a LCD"
+HOMEPAGE="http://www.lcdproc.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz
+ https://raw.githubusercontent.com/lcdproc/lcdproc/master/docs/lcdproc-user/drivers/linux_input.docbook"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug doc ethlcd extra-charmaps freetype menu nfs png samba test-menu"
+REQUIRED_USE="ethlcd? ( lcd_devices_hd44780 )
+ freetype? ( lcd_devices_glcd )
+ png? ( lcd_devices_glcd )"
+
+# Define the list of valid lcd devices.
+# Some drivers were removed from this list:
+# - svga: It needs media-libs/svgalib, which is masked and obsolete.
+IUSE_LCD_DEVICES=( bayrad CFontz CFontzPacket curses CwLnx ea65
+ EyeboxOne futaba g15 glcd glcdlib glk hd44780 i2500vfd
+ icp_a106 imon imonlcd IOWarrior irman irtrans
+ joy lb216 lcdm001 lcterm linux_input lirc lis MD8800 mdm166a
+ ms6931 mtc_s16209x MtxOrb mx5000 NoritakeVFD
+ Olimex_MOD_LCD1x9 picolcd pyramid rawserial
+ sdeclcd sed1330 sed1520 serialPOS serialVFD
+ shuttleVFD sli stv5730 SureElec t6963 text
+ tyan ula200 vlsys_m428 xosd yard2LCD )
+
+# Add supported drivers from 'IUSE_LCD_DEVICES' to 'IUSE' and 'REQUIRED_USE'
+REQUIRED_USE+=" || ( "
+for LCD_DEVICE in "${IUSE_LCD_DEVICES[@]}"; do
+ LCD_DEVICE="${LCD_DEVICE,,}"
+ IUSE+=" lcd_devices_${LCD_DEVICE} "
+ REQUIRED_USE+=" lcd_devices_${LCD_DEVICE} "
+done
+REQUIRED_USE+=" ) "
+unset LCD_DEVICE
+
+# Define dependencies for all drivers in 'IUSE_LCD_DEVICES'
+DEPEND_LCD_DEVICES="lcd_devices_cfontz? ( dev-libs/libhid:= )
+ lcd_devices_cfontzpacket? ( dev-libs/libhid:= )
+ lcd_devices_cwlnx? ( dev-libs/libhid:= )
+ lcd_devices_futaba? ( virtual/libusb:1= )
+ lcd_devices_g15? ( app-misc/g15daemon
+ dev-libs/libg15render:=
+ virtual/libusb:0= )
+ lcd_devices_glcd? ( app-misc/glcdprocdriver:=
+ dev-embedded/libftdi:1=
+ dev-libs/libhid:=
+ dev-libs/serdisplib:=
+ virtual/libusb:0=
+ x11-libs/libX11:= )
+ lcd_devices_hd44780? ( dev-embedded/libftdi:1=
+ dev-libs/libugpio:=
+ virtual/libusb:0= )
+ lcd_devices_i2500vfd? ( dev-embedded/libftdi:1= )
+ lcd_devices_irman? ( media-libs/libirman:= )
+ lcd_devices_iowarrior? ( virtual/libusb:0= )
+ lcd_devices_lirc? ( app-misc/lirc )
+ lcd_devices_lis? ( dev-embedded/libftdi:1= )
+ lcd_devices_lb216? ( dev-libs/libhid:= )
+ lcd_devices_mdm166a? ( dev-libs/libhid:= )
+ lcd_devices_mtc_s16209x? ( dev-libs/libhid:= )
+ lcd_devices_mx5000? ( app-misc/mx5000tools )
+ lcd_devices_noritakevfd? ( dev-libs/libhid:= )
+ lcd_devices_picolcd? ( virtual/libusb:1= )
+ lcd_devices_shuttlevfd? ( virtual/libusb:0= )
+ lcd_devices_ula200? ( dev-embedded/libftdi:1= )
+ lcd_devices_xosd? ( x11-libs/libX11:=
+ x11-libs/xosd:= )"
+
+RDEPEND="${DEPEND_LCD_DEVICES}"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot]
+ app-text/xmlto )
+ freetype? ( media-libs/freetype:2= )
+ nfs? ( net-fs/nfs-utils )
+ png? ( media-libs/libpng:0= )
+ samba? ( net-fs/samba )"
+
+DOCS=( "CREDITS.md" "TODO" )
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-parallel-make.patch"
+ "${FILESDIR}/${P}-use-freetype2-pkg-config.patch"
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ # Copy missing docbook or the buildung of the lcdproc-user docbook will fail
+ cp "${DISTDIR}"/linux_input.docbook "${S}"/docs/lcdproc-user/drivers/linux_input.docbook || die
+}
+
+src_prepare() {
+ default
+
+ # Fix path for modules
+ sed -e "37s:server/drivers:/usr/$(get_libdir)/lcdproc:" -i LCDd.conf || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Enable all users enabled lcd devices
+ local myeconfargs_lcd_devices
+ for lcd_device in "${IUSE_LCD_DEVICES[@]}"; do
+ if use "lcd_devices_${lcd_device,,}"; then
+ myeconfargs_lcd_devices+=",${lcd_device}"
+ fi
+ done
+
+ local enable_ftdi="--disable-libftdi"
+ if use lcd_devices_glcd || use lcd_devices_hd44780 || use lcd_devices_i2500vfd || use lcd_devices_lis || use lcd_devices_ula200; then
+ enable_ftdi="--enable-libftdi"
+ fi
+
+ local enable_hid="--disable-libhid"
+ if use lcd_devices_cfontz || use lcd_devices_cfontzpacket || use lcd_devices_cwlnx || use lcd_devices_glcd || use lcd_devices_lb216 || use lcd_devices_mdm166a || use lcd_devices_mtc_s16209x || use lcd_devices_noritakevfd; then
+ enable_hid="--enable-libhid"
+ fi
+
+ local enable_png="--disable-libpng"
+ use lcd_devices_glcd && enable_png=""
+
+ local enable_usb0="--disable-libusb"
+ if use lcd_devices_futaba || use lcd_devices_g15 || use lcd_devices_glcd || use lcd_devices_hd44780 || use lcd_devices_iowarrior || use lcd_devices_picolcd || use lcd_devices_shuttlevfd; then
+ enable_usb0="--enable-libusb"
+ fi
+
+ local enable_usb1="--disable-libusb-1-0"
+ if use lcd_devices_futaba || use lcd_devices_picolcd; then
+ enable_usb1="--enable-libusb-1-0"
+ fi
+
+ local enable_x11="--disable-libX11"
+ use lcd_devices_glcd && enable_x11="--enable-libX11"
+
+ local myeconfargs=(
+ --enable-drivers="${myeconfargs_lcd_devices#,}"
+ $(use_enable debug)
+ $(use_enable doc doxygen)
+ $(use_enable doc dot)
+ $(use_enable doc html-dox)
+ $(use_enable doc latex-dox)
+ $(use_enable ethlcd)
+ $(use_enable extra-charmaps)
+ $(use_enable freetype)
+ $(use_enable menu lcdproc-menus)
+ $(use_enable nfs stat-nfs)
+ $(use_enable samba stat-smbfs)
+ $(use_enable test-menu testmenus)
+ ${enable_ftdi}
+ ${enable_hid}
+ ${enable_png}
+ ${enable_usb0}
+ ${enable_usb1}
+ ${enable_x11}
+ --with-lcdport="13666"
+ --with-pidfile-dir="/run"
+ --without-included-getopt
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake dox
+
+ local docbook
+ for docbook in lcdproc-user lcdproc-dev; do
+ cd "${S}"/docs/"${docbook}" || die
+ xmlto html "${docbook}".docbook || die
+ done
+ fi
+}
+
+src_install() {
+ default
+
+ # Move example clients from '/usr/bin' into '/usr/share/lcdproc/clients'
+ rm -f "${ED%/}"/usr/bin/{fortune,lcdident,lcdmetar,iosock,tail,x11amp}.pl || die
+ insinto /usr/share/lcdproc/clients
+ doins clients/examples/*.pl clients/metar/*.pl
+
+ newinitd "${FILESDIR}"/LCDd.initd LCDd
+ newinitd "${FILESDIR}"/lcdexec.initd lcdexec
+ newinitd "${FILESDIR}"/lcdproc.initd lcdproc
+
+ systemd_dounit "${FILESDIR}"/LCDd.service
+ systemd_dounit "${FILESDIR}"/lcdexec.service
+ systemd_dounit "${FILESDIR}"/lcdproc.service
+
+ if use doc; then
+ dodoc -r docs/html
+
+ local docbook
+ for docbook in lcdproc-user lcdproc-dev; do
+ docinto "${docbook}"
+ dodoc docs/"${docbook}"/*.html
+ done
+ fi
+}
diff --git a/app-misc/lcdproc/metadata.xml b/app-misc/lcdproc/metadata.xml
index 863d531d0995..ab8591e847e6 100644
--- a/app-misc/lcdproc/metadata.xml
+++ b/app-misc/lcdproc/metadata.xml
@@ -5,25 +5,38 @@
<email>xmw@gentoo.org</email>
<name>Michael Weber</name>
</maintainer>
- <longdescription lang="en">
- LCDproc is a piece of software that displays real-time system information
- from your Linux/*BSD box on a LCD. The server supports several serial
- devices: Matrix Orbital, CrystalFontz, Bayrad, LB216, LCDM001
- (kernelconcepts.de), Wirz-SLI, Cwlinux(.com) and PIC-an-LCD; and some
- devices connected to the LPT port: HD44780, STV5730, T6963, SED1520 and
- SED1330. Various clients are available that display things like CPU load,
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ LCDproc is a piece of open source software that displays real-time system information
+ from your Linux/*BSD box on a LCD. The server supports several serial and USB devices
+ from Matrix Orbital and CrystalFontz as well as
+ some devices connected to the LPT port: HD44780, T6963, SED1520 and SED1330.
+ Various clients are available that display things like CPU load,
system load, memory usage, uptime, and a lot more.
</longdescription>
<use>
- <flag name="hid">Enable HID support using libhid</flag>
- <flag name="irman">Enable support for IRMan (<pkg>media-libs/libirman</pkg>)</flag>
- <flag name="nfs">Adds support for NFS file system</flag>
- <flag name="seamless-hbars">Try to avoid gaps in horizontal bars</flag>
- <flag name="ftdi">Enable support for FTDI connections in some selected LCD_DEVICES (currently hd44780)</flag>
- <flag name="lcd_devices_sdeclcd">Enable support for VLSYS M428 display</flag>
- <flag name="lcd_devices_vlsys_m428">Enable support for VLSYS M428 display</flag>
+ <flag name="ethlcd">Enable support for ethlcd in the hd44780 driver.</flag>
+ <flag name="extra-charmaps">Enable extra language specific charmaps.</flag>
+ <flag name="freetype">Enable support for <pkg>media-libs/freetype</pkg> in the glcd driver.</flag>
+ <flag name="ftdi">Enable support for <pkg>dev-embedded/libftdi</pkg> in the glcd,hd44780,i2500vfd,lis and ula200 driver.</flag>
+ <flag name="hid">Enable support for <pkg>dev-libs/libhid</pkg> in the cfontz,cfontzpacket,cwlnx,glcd,lb216,mdm166a,mtc_s16209x and noritakevfd driver.</flag>
+ <flag name="irman">Enable support for <pkg>media-libs/libirman</pkg> in the irman driver.</flag>
+ <flag name="menu">Enable menu support in the lcdproc client.</flag>
+ <flag name="nfs">Display NFS filesystem stats in the lcdproc client.</flag>
+ <flag name="png">Enable support for <pkg>media-libs/libpng</pkg> in the glcd driver.</flag>
+ <flag name="samba">Display SMBFS filesystem stats in the lcdproc client.</flag>
+ <flag name="seamless-hbars">Don't produce any gaps in horizontal bar graphs, if hardware supports it.</flag>
+ <flag name="test-menu">Enable test menu support for the lcdproc server.</flag>
</use>
<upstream>
- <remote-id type="sourceforge">lcdproc</remote-id>
+ <bugs-to>https://www.github.com/lcdproc/lcdproc/issues</bugs-to>
+ <remote-id type="github">lcdproc/lcdproc</remote-id>
</upstream>
</pkgmetadata>