summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ola/Manifest1
-rw-r--r--app-misc/ola/files/ola-0.10.8-python_version_check.patch31
-rw-r--r--app-misc/ola/ola-0.10.8.ebuild114
3 files changed, 0 insertions, 146 deletions
diff --git a/app-misc/ola/Manifest b/app-misc/ola/Manifest
index c98814f9b31a..2f4d34ce54a6 100644
--- a/app-misc/ola/Manifest
+++ b/app-misc/ola/Manifest
@@ -1,2 +1 @@
-DIST ola-0.10.8.tar.gz 2552023 BLAKE2B b4fa7e36e2b907e8f0ea16ef089607fc223afc543752a03740fd1d525062ea676d2f392bb623804543827d6f5ac6078c469a3edcb4321bca9a454b1c219f9c89 SHA512 78ef8cc7f8e8d0b1d15bbb305d99a589fce82e07e89ca3bf2466bef8cdc1b18f590fc8dcbf29fc5af2349e0721c832f525fd665d62498907554ee742d79cd3d2
DIST ola-0.10.9.tar.gz 2578760 BLAKE2B 8cace370b21788d0fe65e56d33fdc9436a5103837d370e3e7e07b43318d4ec3b29536b55c4b117f515a4698ebab88f58718759a0cf9a00f79d0b839e7a79d581 SHA512 e8e2f4249d6e1f63f6c36ae548d9e3a82080f0da82829f923ba6b4d63685fb89f9baccf4588fd6fcbf756708d91e27d022c0d623e7c03c84ec058e7dc7c46bdf
diff --git a/app-misc/ola/files/ola-0.10.8-python_version_check.patch b/app-misc/ola/files/ola-0.10.8-python_version_check.patch
deleted file mode 100644
index a4a82f916fa0..000000000000
--- a/app-misc/ola/files/ola-0.10.8-python_version_check.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/python/ola/OlaClient.py
-+++ b/python/ola/OlaClient.py
-@@ -952,7 +952,7 @@
- controller = SimpleRpcController()
- request = Ola_pb2.DmxData()
- request.universe = universe
-- if sys.version >= '3.2':
-+ if sys.version_info[:3] >= (3,2):
- request.data = data.tobytes()
- else:
- request.data = data.tostring()
---- a/python/ola/PidStore.py
-+++ b/python/ola/PidStore.py
-@@ -645,7 +645,7 @@
- (self.name, self.min))
-
- try:
-- if sys.version >= '3.2':
-+ if sys.version_info[:3] >= (3,2):
- data = struct.unpack('%ds' % arg_size, bytes(arg, 'utf8'))
- else:
- data = struct.unpack('%ds' % arg_size, arg)
-@@ -668,7 +668,7 @@
- except struct.error as e:
- raise UnpackException(e)
-
-- if sys.version >= '3.2':
-+ if sys.version_info[:3] >= (3,2):
- return value[0].rstrip(b'\x00').decode('utf-8')
- else:
- return value[0].rstrip(b'\x00')
diff --git a/app-misc/ola/ola-0.10.8.ebuild b/app-misc/ola/ola-0.10.8.ebuild
deleted file mode 100644
index 895c098489fe..000000000000
--- a/app-misc/ola/ola-0.10.8.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="Open Lighting Architecture, a framework for lighting control information"
-HOMEPAGE="https://www.openlighting.org/ola/"
-SRC_URI="https://github.com/OpenLightingProject/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples ftdi http osc python rdm-tests tcmalloc test usb zeroconf"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
- rdm-tests? ( python )"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/protobuf:=
- sys-apps/util-linux
- sys-libs/ncurses
- ftdi? ( dev-embedded/libftdi:1 )
- http? ( net-libs/libmicrohttpd:= )
- osc? ( media-libs/liblo )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- ')
- )
- rdm-tests? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
- tcmalloc? ( dev-util/google-perftools:= )
- usb? ( virtual/libusb:1 )
- zeroconf? ( net-dns/avahi )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-BDEPEND="sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
- test? (
- dev-util/cppunit
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- ')
- )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.10.8-python_version_check.patch
-)
-
-src_prepare() {
- default
- # Upstream recommends doing this even for tarball builds
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-fatal-warnings
- --with-uucp-lock="/run"
- $(use_enable doc doxygen-doc)
- $(use_enable doc doxygen-dot)
- $(use_enable examples)
- $(use_enable ftdi libftdi)
- $(use_enable http)
- $(use_enable osc)
- $(use_enable python python-libs)
- $(use_enable rdm-tests)
- $(use_enable tcmalloc)
- $(use_enable test unittests)
- $(use_enable usb libusb)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
- use doc && emake doxygen-doc
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- if use doc; then
- dodoc -r html
- docompress -x /usr/share/doc/${PF}/html
- fi
-
- if use examples && use python; then
- docinto examples
- python_fix_shebang python/examples/*.py
- dodoc python/examples/*.py
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}