summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/FreeSSM/FreeSSM-1.2.5_p20210702.ebuild48
-rw-r--r--app-misc/FreeSSM/FreeSSM-9999.ebuild51
-rw-r--r--app-misc/FreeSSM/Manifest1
-rw-r--r--app-misc/FreeSSM/metadata.xml20
4 files changed, 120 insertions, 0 deletions
diff --git a/app-misc/FreeSSM/FreeSSM-1.2.5_p20210702.ebuild b/app-misc/FreeSSM/FreeSSM-1.2.5_p20210702.ebuild
new file mode 100644
index 000000000000..a0c2947d8f02
--- /dev/null
+++ b/app-misc/FreeSSM/FreeSSM-1.2.5_p20210702.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils desktop
+
+DESCRIPTION="Free and easy to use diagnostic and adjustment tool for SUBARU® vehicles"
+HOMEPAGE="https://github.com/Comer352L/FreeSSM"
+
+GIT_COMMIT="97576c03578ec8564b5db67d59fb52502ad7a932"
+SRC_URI="https://github.com/Comer352L/FreeSSM/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="small-resolution"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+
+src_configure() {
+ eqmake5 FreeSSM.pro $(usex small-resolution CONFIG+=small-resolution "")
+}
+
+src_compile() {
+ emake release
+ emake translation
+}
+
+src_install() {
+ local installdir="/usr/share/${PN}"
+ eqmake5 INSTALLDIR="${D}${installdir}"
+ emake release-install
+
+ make_desktop_entry "${installdir}/${PN}" ${PN} "${installdir}/${PN}.png"
+}
diff --git a/app-misc/FreeSSM/FreeSSM-9999.ebuild b/app-misc/FreeSSM/FreeSSM-9999.ebuild
new file mode 100644
index 000000000000..916c0c65d2da
--- /dev/null
+++ b/app-misc/FreeSSM/FreeSSM-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils desktop
+
+DESCRIPTION="Free and easy to use diagnostic and adjustment tool for SUBARU® vehicles"
+HOMEPAGE="https://github.com/Comer352L/FreeSSM"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Comer352L/FreeSSM.git"
+else
+ SRC_URI="https://github.com/Comer352L/FreeSSM/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="small-resolution"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+"
+DEPEND="
+ ${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 FreeSSM.pro $(usex small-resolution CONFIG+=small-resolution "")
+}
+
+src_compile() {
+ emake release
+ emake translation
+}
+
+src_install() {
+ local installdir="/usr/share/${PN}"
+
+ eqmake5 INSTALLDIR="${D}${installdir}"
+ emake release-install
+
+ make_desktop_entry "${installdir}/${PN}" ${PN} "${installdir}/${PN}.png"
+}
diff --git a/app-misc/FreeSSM/Manifest b/app-misc/FreeSSM/Manifest
new file mode 100644
index 000000000000..93f34d385d56
--- /dev/null
+++ b/app-misc/FreeSSM/Manifest
@@ -0,0 +1 @@
+DIST FreeSSM-1.2.5_p20210702.tar.gz 1422551 BLAKE2B d9f3219f225cc2678773a20afa78eee3249a1043f354dfab64eb11debfde8d66b4f0e6fe6b9252e98fccc9b29fb105712fa3da491007f285179fe5060547da20 SHA512 72f8883ee44a056ed3886a7cab5186c45e1f1b571195de9d556805e90d178efd2b25460a7b87c7c4a727807ada04199c2131aef509d8aa0e68eab1b664b63411
diff --git a/app-misc/FreeSSM/metadata.xml b/app-misc/FreeSSM/metadata.xml
new file mode 100644
index 000000000000..ceb4e3b061db
--- /dev/null
+++ b/app-misc/FreeSSM/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fordfrog@gentoo.org</email>
+ <description>Miroslav Šulc</description>
+ </maintainer>
+ <longdescription>
+ FreeSSM is a free and easy to use diagnostic and adjustment tool for SUBARU®
+ vehicles. It currently supports the models LEGACY®, LIBERTY®, OUTBACK®, BAJA®,
+ IMPREZA®, FORESTER® and TRIBECA® starting with model year 1999 and provides
+ access to the engine and transmission control units.
+ </longdescription>
+ <use>
+ <flag name="small-resolution">Build the app for small resolution screeens</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Comer352L/FreeSSM</remote-id>
+ </upstream>
+</pkgmetadata>