summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xmind/xmind-3.5.3.201506180105-r2.ebuild17
-rw-r--r--app-misc/xmind/xmind-3.7.6_p201801311814.ebuild16
2 files changed, 8 insertions, 25 deletions
diff --git a/app-misc/xmind/xmind-3.5.3.201506180105-r2.ebuild b/app-misc/xmind/xmind-3.5.3.201506180105-r2.ebuild
index dfb4046680b1..1851c251719c 100644
--- a/app-misc/xmind/xmind-3.5.3.201506180105-r2.ebuild
+++ b/app-misc/xmind/xmind-3.5.3.201506180105-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit desktop eutils multilib gnome2-utils
+inherit desktop eutils multilib optfeature xdg
MY_PN="${PN}-portable"
MY_P="${MY_PN}-${PV}"
@@ -15,7 +15,6 @@ SRC_URI="http://dl2.xmind.net/xmind-downloads/${MY_P}.zip
LICENSE="EPL-1.0 LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
DEPEND="app-arch/unzip"
RDEPEND="
@@ -75,15 +74,7 @@ src_install() {
make_desktop_entry ${PN} "XMind" ${PN} "Office" "MimeType=application/x-xmind;"
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- gnome2_icon_cache_update
- elog "For audio notes support, install media-sound/lame"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_pkg_postinst
+ optfeature "audio notes support" media-sound/lame
}
diff --git a/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild b/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
index 03ce175e13f3..67866d5575d9 100644
--- a/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
+++ b/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit desktop font gnome2-utils
+inherit desktop font optfeature xdg
MY_PV="8-update7"
MY_P="${PN}-${MY_PV}-linux"
@@ -78,16 +78,8 @@ src_install() {
font_src_install
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- gnome2_icon_cache_update
font_pkg_postinst
- elog "For audio notes support, install media-sound/lame"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_pkg_postinst
+ optfeature "audio notes support" media-sound/lame
}