summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fdupes/fdupes-9999.ebuild15
-rw-r--r--app-misc/fdupes/files/fdupes-9999-gentoo.patch14
-rw-r--r--app-misc/fdupes/files/fdupes-9999-makefile.patch28
3 files changed, 21 insertions, 36 deletions
diff --git a/app-misc/fdupes/fdupes-9999.ebuild b/app-misc/fdupes/fdupes-9999.ebuild
index 21737cbeea01..c9a2c595d3cc 100644
--- a/app-misc/fdupes/fdupes-9999.ebuild
+++ b/app-misc/fdupes/fdupes-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils flag-o-matic git-r3 toolchain-funcs
+inherit flag-o-matic git-r3 toolchain-funcs
MY_P="${PN}-${PV/_pre/-PR}"
@@ -15,20 +15,19 @@ EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE=""
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch
-
+src_configure() {
append-lfs-flags
tc-export CC
}
src_install() {
dobin fdupes
+ dodoc CHANGES CONTRIBUTORS README
doman fdupes.1
- dodoc CHANGES CONTRIBUTORS README TODO
}
diff --git a/app-misc/fdupes/files/fdupes-9999-gentoo.patch b/app-misc/fdupes/files/fdupes-9999-gentoo.patch
new file mode 100644
index 000000000000..4c6edda50e04
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-9999-gentoo.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -71,9 +71,9 @@
+ # Make Configuration
+ #
+ CC ?= gcc
+-COMPILER_OPTIONS = -Wall -O -g
++COMPILER_OPTIONS = -Wall
+
+-CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
++CFLAGS += $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
+
+ INSTALL_PROGRAM = $(INSTALL) -c -m 0755
+ INSTALL_DATA = $(INSTALL) -c -m 0644
diff --git a/app-misc/fdupes/files/fdupes-9999-makefile.patch b/app-misc/fdupes/files/fdupes-9999-makefile.patch
deleted file mode 100644
index b534c6488573..000000000000
--- a/app-misc/fdupes/files/fdupes-9999-makefile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
- Makefile | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 921d910..67576f9 100644
---- a/Makefile
-+++ b/Makefile
-@@ -78,9 +78,9 @@ MKDIR = mkdir -p
- # Make Configuration
- #
- CC ?= gcc
--COMPILER_OPTIONS = -Wall -O -g
-+CFLAGS ?= -Wall -O -g
-
--CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
-+CFLAGS += -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
-
- INSTALL_PROGRAM = $(INSTALL) -c -m 0755
- INSTALL_DATA = $(INSTALL) -c -m 0644
-@@ -100,7 +100,7 @@ OBJECT_FILES = fdupes.o md5/md5.o $(ADDITIONAL_OBJECTS)
- all: fdupes
-
- fdupes: $(OBJECT_FILES)
-- $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o fdupes $(OBJECT_FILES)
-
- installdirs:
- test -d $(DESTDIR)$(BIN_DIR) || $(MKDIR) $(DESTDIR)$(BIN_DIR)