summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-3.36.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index ab5940e051d0..e8f93da9b9ef 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1 +1,2 @@
DIST gnote-3.30.0.tar.xz 4017364 BLAKE2B e53240162d4814a0f004863ca5d309dce0b428d8ce4f7e8dc64c0ce683a830ebedc4809191e55818dba98de7d968413ae080f86367abacf3e4f3a404bbd62157 SHA512 7c1348b9fdbc84ea8cc74e214de50b594a1585031a40406ba73a8635362ef1769a37dbce79347188983970debf72d3c0f81523739a48bf27823f0233cc6cfd2b
+DIST gnote-3.36.1.tar.xz 3512000 BLAKE2B 00f5f8049085c855722f92fb3231684d53c4a15b96b7148a2a810d8fdd4c02b22510f4c4f9296fd7e2f4ba96e44d55215f71a2eb78ecb60170f8bb7ffbdef6ef SHA512 4c0c9d469836366a7886928beb0b47c48e60ee41591de193b9af597214f373c2c14b25745f6238ccbede8df8e7d4d83f39a34aed1b155895479bba3e043d2cce
diff --git a/app-misc/gnote/gnote-3.36.1.ebuild b/app-misc/gnote/gnote-3.36.1.ebuild
new file mode 100644
index 000000000000..95d5527ca525
--- /dev/null
+++ b/app-misc/gnote/gnote-3.36.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gspell-1.6.0:=
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}