summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/bitpim/files')
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch12
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch22
-rw-r--r--app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch90
-rwxr-xr-xapp-mobilephone/bitpim/files/maketarball30
4 files changed, 0 insertions, 154 deletions
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch
deleted file mode 100644
index 2a5b7cb5237b..000000000000
--- a/app-mobilephone/bitpim/files/bitpim-1.0.6-ffmpeg_quality.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nru bitpim-1.0.6.orig/src/conversions.py bitpim-1.0.6/src/conversions.py
---- bitpim-1.0.6.orig/src/conversions.py 2008-11-02 13:51:31.000000000 +0000
-+++ bitpim-1.0.6/src/conversions.py 2008-11-02 13:52:21.000000000 +0000
-@@ -239,7 +239,7 @@
- ffmpeg=gethelperbinary("ffmpeg")
- with common.usetempfile('mp3') as mp3file:
- try:
-- run(ffmpeg, "-i", shortfilename(inputfilename), "-hq", "-ab", `bitrate`, "-ar", `samplerate`, "-ac", `channels`, shortfilename(mp3file))
-+ run(ffmpeg, "-i", shortfilename(inputfilename), "-sameq", "-ab", `bitrate`, "-ar", `samplerate`, "-ac", `channels`, shortfilename(mp3file))
- except common.CommandExecutionFailed, e:
- # we get this exception on bad parameters, or any other
- # issue so we assume bad parameters for the moment.
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch
deleted file mode 100644
index dfb02d931a7a..000000000000
--- a/app-mobilephone/bitpim/files/bitpim-1.0.6-gcc43.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/avi_file.cxx bitpim-1.0.6/src/native/av/bmp2avi/avi_file.cxx
---- bitpim-1.0.6.orig/src/native/av/bmp2avi/avi_file.cxx 2005-02-18 06:55:03.000000000 +0000
-+++ bitpim-1.0.6/src/native/av/bmp2avi/avi_file.cxx 2008-11-02 13:54:15.000000000 +0000
-@@ -9,6 +9,7 @@
-
- #include "avi_file.h"
- #include "byte_order.h"
-+#include <cstring>
-
- // endian conversion routines
-
-diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/bmp_file.cxx bitpim-1.0.6/src/native/av/bmp2avi/bmp_file.cxx
---- bitpim-1.0.6.orig/src/native/av/bmp2avi/bmp_file.cxx 2005-02-18 06:55:03.000000000 +0000
-+++ bitpim-1.0.6/src/native/av/bmp2avi/bmp_file.cxx 2008-11-02 13:54:15.000000000 +0000
-@@ -11,6 +11,7 @@
- #include <string>
- #include "bmp_file.h"
- #include "byte_order.h"
-+#include <cstring>
-
- using namespace std;
-
diff --git a/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch
deleted file mode 100644
index ed7f96e62898..000000000000
--- a/app-mobilephone/bitpim/files/bitpim-1.0.6-gentoo.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff -Nru bitpim-1.0.6.orig/src/common.py bitpim-1.0.6/src/common.py
---- bitpim-1.0.6.orig/src/common.py 2007-08-29 00:19:51.000000000 +0000
-+++ bitpim-1.0.6/src/common.py 2008-11-02 13:50:39.000000000 +0000
-@@ -860,7 +860,7 @@
- # windows running from exe, return as is
- return os.path.abspath(os.path.dirname(sys.executable))
- # running from src, up one
-- return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
-+ return os.path.abspath(os.path.dirname(sys.argv[0]))
-
- if sys.platform=='win32':
- # From Tim Golden's Win32 How Do I ...?
-diff -Nru bitpim-1.0.6.orig/src/conversions.py bitpim-1.0.6/src/conversions.py
---- bitpim-1.0.6.orig/src/conversions.py 2007-08-29 00:19:51.000000000 +0000
-+++ bitpim-1.0.6/src/conversions.py 2008-11-02 13:50:39.000000000 +0000
-@@ -23,11 +23,11 @@
-
- class ConversionFailed(Exception): pass
-
--helperdir=os.path.join(common.get_main_dir(), "helpers")
-+helperdir="/usr/bin"
-
- osext={'win32': '.exe',
- 'darwin': '.mbin',
-- 'linux2': '.lbin'} \
-+ 'linux2': ''} \
- [sys.platform]
-
- # This shortname crap is needed because Windows programs (including ffmpeg)
-@@ -128,14 +128,14 @@
- p=sys.path[0]
- if os.path.isfile(p):
- p=os.path.dirname(p)
-- helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
-+ helpersdirectory="/usr/bin"
- print "Helper Directory: "+helpersdirectory
- if sys.platform=='win32':
- osext=".exe"
- if sys.platform=='darwin':
- osext=".mbin"
- if sys.platform=='linux2':
-- osext=".lbin"
-+ osext=""
-
- pngtopnmbin=gethelperbinary('pngtopnm')
- ppmquantbin=gethelperbinary('ppmquant')
-diff -Nru bitpim-1.0.6.orig/src/importexport.py bitpim-1.0.6/src/importexport.py
---- bitpim-1.0.6.orig/src/importexport.py 2007-08-27 04:58:33.000000000 +0000
-+++ bitpim-1.0.6/src/importexport.py 2008-11-02 13:50:39.000000000 +0000
-@@ -23,7 +23,7 @@
- import wx.html
-
- # Others
--from thirdparty import DSV
-+import DSV
-
- # My modules
- import common
-diff -Nru bitpim-1.0.6.orig/src/native/av/bmp2avi/Makefile bitpim-1.0.6/src/native/av/bmp2avi/Makefile
---- bitpim-1.0.6.orig/src/native/av/bmp2avi/Makefile 2006-05-05 07:10:08.000000000 +0000
-+++ bitpim-1.0.6/src/native/av/bmp2avi/Makefile 2008-11-02 13:50:39.000000000 +0000
-@@ -13,6 +13,6 @@
-
- SRC=avi_file.cxx bmp_file.cxx b2a.cxx
-
--bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
-+bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
- $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
-
-diff -Nru bitpim-1.0.6.orig/src/native/usb/build.sh bitpim-1.0.6/src/native/usb/build.sh
---- bitpim-1.0.6.orig/src/native/usb/build.sh 2007-08-10 21:53:59.000000000 +0000
-+++ bitpim-1.0.6/src/native/usb/build.sh 2008-11-02 13:50:39.000000000 +0000
-@@ -4,4 +4,4 @@
- swig -python -I/usr/include libusb.i
-
- gcc -fPIC -Wall -fno-strict-aliasing -O2 -g -shared -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb
--strip _libusb.so
-+#strip _libusb.so
-diff -Nru bitpim-1.0.6.orig/src/phones/com_samsung.py bitpim-1.0.6/src/phones/com_samsung.py
---- bitpim-1.0.6.orig/src/phones/com_samsung.py 2007-08-17 21:11:59.000000000 +0000
-+++ bitpim-1.0.6/src/phones/com_samsung.py 2008-11-02 13:50:39.000000000 +0000
-@@ -16,7 +16,7 @@
- import time
-
- # site-packages
--from thirdparty import DSV
-+import DSV
-
- # BitPim modules
- import bpcalendar
diff --git a/app-mobilephone/bitpim/files/maketarball b/app-mobilephone/bitpim/files/maketarball
deleted file mode 100755
index 8df7f071df9a..000000000000
--- a/app-mobilephone/bitpim/files/maketarball
+++ /dev/null
@@ -1,30 +0,0 @@
-# For building the tarball. To be used only by ebuild maintainers
-DISTDIR=/usr/portage/distfiles
-PN=bitpim
-PV=$1
-P=$PN-$PV
-
-if [ -z "$PV" ]; then
- echo "usage: $0 version"
-else
- svnrev=$(svn log -q --limit 1 https://${PN}.svn.sourceforge.net/svnroot/${PN}/releases/${PV} | sed -r '/^[^r]/d;s/^r([0-9]+) .*$/\1/')
- [ $? = 0 ] || return 1
-
- #Fetch the source (only those directories that are needed)
- cd "${DISTDIR}" && mkdir -p ${P} || return 1
- for x in resources packaging src ; do
- svn export https://${PN}.svn.sourceforge.net/svnroot/${PN}/releases/${PV}/${x} ${P}/${x} || return 1
- done
-
- #Remove unneeded stuff
- rm ${P}/resources/*.chm ${P}/src/package.py
-
- #Freeze version and set vendor name to Gentoo
- sed -i -e 's/\(^__FROZEN__="[$]Id: \).*\( $"\)/\1'${svnrev}'\2/' \
- -e 's/^vendor=".*"/vendor="Gentoo"/' \
- ${P}/src/version.py || return 1
-
- #Make the tarball
- tar -cjf ${P}.tar.bz2 ${P}
- rm -r ${P}
-fi