summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/gammu/files/gammu-skip-locktest.patch')
-rw-r--r--app-mobilephone/gammu/files/gammu-skip-locktest.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/files/gammu-skip-locktest.patch b/app-mobilephone/gammu/files/gammu-skip-locktest.patch
new file mode 100644
index 000000000000..a509879d5edb
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-skip-locktest.patch
@@ -0,0 +1,12 @@
+diff -Nru tests/CMakeLists.txt tests/CMakeLists.txt
+--- tests/CMakeLists.txt 2009-09-04 10:56:25.000000000 +0200
++++ tests/CMakeLists.txt 2009-09-05 07:46:58.000000000 +0200
+@@ -739,7 +739,7 @@
+
+ # Test for locking, only on !WIN32 and if we can write to lock dir
+ if (NOT WIN32)
+- execute_process(COMMAND test -w /var/lock/ RESULT_VARIABLE VAR_LOCK_WRITABLE)
++ set (VAR_LOCK_WRITABLE 1)
+ if (VAR_LOCK_WRITABLE EQUAL 0)
+ add_executable(locking locking.c)
+ target_link_libraries(locking libGammu)