summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/smstools/files')
-rw-r--r--app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch38
-rw-r--r--app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch9
-rw-r--r--app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch11
-rwxr-xr-xapp-mobilephone/smstools/files/smsd.initd21
-rw-r--r--app-mobilephone/smstools/files/smsd.initd222
-rw-r--r--app-mobilephone/smstools/files/smsd.initd331
-rw-r--r--app-mobilephone/smstools/files/smsd.service11
-rw-r--r--app-mobilephone/smstools/files/smsd.tmpfiles1
8 files changed, 144 insertions, 0 deletions
diff --git a/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch b/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch
new file mode 100644
index 000000000000..64336eed98a1
--- /dev/null
+++ b/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch
@@ -0,0 +1,38 @@
+--- src/extras.c.orig 2006-06-15 10:45:59.000000000 +0100
++++ src/extras.c 2006-06-15 10:45:39.000000000 +0100
+@@ -178,20 +178,21 @@
+ stat(filename,&statbuf);
+ if (S_ISDIR(statbuf.st_mode)==0) /* Is this a directory? */
+ {
+- /* File found, check for lock file */
+- if (strstr(filename,".LOCK")==0) /* Is the file a lock file itself? */
+- if (!islocked(filename)) /* no, is there a lock file for this file? */
+- {
+- /* check if the file grows at the moment (another program writes to it) */
+- int groesse1;
+- int groesse2;
+- groesse1=statbuf.st_size;
+- sleep(1);
+- stat(filename,&statbuf);
+- groesse2=statbuf.st_size;
+- if (groesse1==groesse2)
+- found=1;
+- }
++ /* File found, check for lock file and skip portage directory locks */
++ if (strstr(filename,".keep")==0) /* Is it a portage directory lock? */
++ if (strstr(filename,".LOCK")==0) /* Is the file a lock file itself? */
++ if (!islocked(filename)) /* no, is there a lock file for this file? */
++ {
++ /* check if the file grows at the moment (another program writes to it) */
++ int groesse1;
++ int groesse2;
++ groesse1=statbuf.st_size;
++ sleep(1);
++ stat(filename,&statbuf);
++ groesse2=statbuf.st_size;
++ if (groesse1==groesse2)
++ found=1;
++ }
+ }
+ }
+ closedir(dirdata);
diff --git a/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch b/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch
new file mode 100644
index 000000000000..716e316c487e
--- /dev/null
+++ b/app-mobilephone/smstools/files/2.2.13-sendsms-chmod.patch
@@ -0,0 +1,9 @@
+diff -uNr smstools.ORIG/scripts/sendsms smstools/scripts/sendsms
+--- smstools.ORIG/scripts/sendsms 2006-12-02 15:26:09.000000000 +0000
++++ smstools/scripts/sendsms 2006-12-02 15:26:52.000000000 +0000
+@@ -26,3 +26,5 @@
+ echo "" >> $FILE
+ echo -n "$TEXT" >> $FILE
+
++chmod 660 $FILE
++
diff --git a/app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch b/app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch
new file mode 100644
index 000000000000..70455bef6c56
--- /dev/null
+++ b/app-mobilephone/smstools/files/3.1.15-makefile-whitespace.patch
@@ -0,0 +1,11 @@
+--- smstools3/src/Makefile.old 2014-04-25 23:28:46.324045112 +1000
++++ smstools3/src/Makefile 2014-04-25 23:33:26.453061496 +1000
+@@ -43,7 +43,7 @@
+
+ ifneq (,$(findstring SOLARIS,$(CFLAGS)))
+ ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
+-override LFLAGS += -lsocket -lnsl
++ override LFLAGS += -lsocket -lnsl
+ endif
+ endif
+
diff --git a/app-mobilephone/smstools/files/smsd.initd b/app-mobilephone/smstools/files/smsd.initd
new file mode 100755
index 000000000000..849449dc48bc
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting smsd"
+ start-stop-daemon -b -m -p /var/run/smsd.pid -c smsd:sms --start --exec /usr/bin/smsd -- \
+ -c /etc/smsd.conf
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping smsd"
+ start-stop-daemon --stop -p /var/run/smsd.pid
+ eend ${?}
+}
diff --git a/app-mobilephone/smstools/files/smsd.initd2 b/app-mobilephone/smstools/files/smsd.initd2
new file mode 100644
index 000000000000..b6117ab1abf5
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.initd2
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+start() {
+ chown smsd:sms /var/log/smsd.log
+ ebegin "Starting smsd"
+ start-stop-daemon -b -u smsd:sms --start --exec /usr/bin/smsd -- \
+ -c /etc/smsd.conf
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping smsd"
+ start-stop-daemon --stop -n smsd
+ eend ${?}
+}
diff --git a/app-mobilephone/smstools/files/smsd.initd3 b/app-mobilephone/smstools/files/smsd.initd3
new file mode 100644
index 000000000000..1f585946a448
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.initd3
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+start() {
+ if ! [ -d /var/run/smsd ]; then
+ ebegin "Creating /var/run/smsd for ${SVCNAME}"
+ mkdir /var/run/smsd \
+ && chown smsd:sms /var/run/smsd \
+ && chmod 770 /var/run/smsd
+ eend $?
+ fi
+
+ chown smsd:sms /var/log/smsd.log
+ ebegin "Starting smsd"
+ start-stop-daemon -b -u smsd:sms --start --exec /usr/bin/smsd -- \
+ -c /etc/smsd.conf -p /var/run/smsd/smsd.pid \
+ -i /var/run/smsd/smsd.working
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping smsd"
+ start-stop-daemon --stop -n smsd
+ eend ${?}
+}
diff --git a/app-mobilephone/smstools/files/smsd.service b/app-mobilephone/smstools/files/smsd.service
new file mode 100644
index 000000000000..1fb436681b4b
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=SMS Server Tools 3
+
+[Service]
+User=smsd
+PIDFile=/run/smsd/smsd.pid
+ExecStart=/usr/bin/smsd -n MAINPROCESS -l/var/log/smsd.log \
+ -p/run/smsd/smsd.pid -i/run/smsd/smsd.working
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-mobilephone/smstools/files/smsd.tmpfiles b/app-mobilephone/smstools/files/smsd.tmpfiles
new file mode 100644
index 000000000000..8978d18f54ad
--- /dev/null
+++ b/app-mobilephone/smstools/files/smsd.tmpfiles
@@ -0,0 +1 @@
+d /run/smsd 0755 smsd sms -